PDA

View Full Version : Installed, yet NO boot



gamezealot
01-19-2005, 03:29 PM
Ok, I'm a relatively new linux user. I booted off the knoppix cd and opened terminal... typed su, and then typed the command to start the installer. Everytime it says I dont meet the minimum requirements.... I'm installing Knoppix on my second internal drive. I made a 500mb linux swap partition, and the rest is a linux partition, marked as bootable, about 55 gb worth. So i did the ignorecheck=1 thing and forced the install to start. It went through, got to the point where it was asking for a floppy, I hit no because I dont have one. Then it said installation complete.... I restart and i can only boot to windows..... I boot back up off the cd, and HD shows all these new files, but I cannot boot off the second drive.... any suggestions? did I miss anything? is the floppy part important?

rrfish72
01-19-2005, 04:58 PM
Did you make sure to install the bootloader to the mbr? It will not boot when you choose the root partition.

gamezealot
01-19-2005, 05:55 PM
when was i supposed to do that? how do I do that?

also.... is a floppy drive neccessary to install?

rrfish72
01-19-2005, 07:07 PM
During the install process that is one of the options that you are given to configure. Just make sure that it is checked or that the dot is in between the parenthesis. No floppy needed to install when doing from live cd.

gamezealot
01-20-2005, 01:37 AM
ok... cool, ill try again once i get home.... but one other question.... what exactly do I need for it to recognize i have my drive partitioned correctly.... i have a linux swap partition, and a regular linux partition set to bootable..... but it keeps saying i dont have the requirements and I have to force it to install

CrashedAgain
01-20-2005, 02:03 AM
Ok, I'm a relatively new linux user. I booted off the knoppix cd and opened terminal... typed su, and then typed the command to start the installer. Everytime it says I dont meet the minimum requirements.... I'm installing Knoppix on my second internal drive. I made a 500mb linux swap partition, and the rest is a linux partition, marked as bootable, about 55 gb worth. So i did the ignorecheck=1 thing and forced the install to start. It went through, got to the point where it was asking for a floppy, I hit no because I dont have one. Then it said installation complete.... I restart and i can only boot to windows..... I boot back up off the cd, and HD shows all these new files, but I cannot boot off the second drive.... any suggestions? did I miss anything? is the floppy part important?
It sounds like the lilo bootloader did not install properly. Boot your knoppix CD with the bootcode 'knoppix root=/dev/hda5 noinitrd ro' (replace hda5 with the correct partition for where you installed knoppix to). This should start your konppix HD installation. Using konqueror, browse to /etc/lilo.conf & open the file. Check that there is a line which says 'boot=/dev/hda', this is the command to put lilo on the MBR. If this is correct, open a terminal & type 'sudo lilo' which should attempt to install lilo on your MBR. Follow up on any error messages or post again if you get any error messages. To edit lilo.conf to correct any errors you will have to be root user.
To edit this file using kate (easier than most text based editors), first type 'sudo passwd' & set a root password then type 'kdesu kate /etc/lilo.conf' to open the editor as root. You should make a bakup copy first 'sudo cp /etc/lilo.conf /etc/lilo.conf.old' willmake a backup copy.

gamezealot
01-20-2005, 03:45 AM
ok, lilo did have that boot=/dev/hda

so i typed sudo lilo in the terminal and this is what I got

knoppix@1[~]$ sudo lilo
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Warning: Unable to determine video adapter in use in the present system.
Warning: The boot sector and map file are on different disks.
Added Linux *
Added Linux(2.4)-1
Added Linux(2.6)-2
Warning: CHANGE AUTOMATIC assumed after "other=/dev/hda1"
Added Windows(hda1)
Warning: CHANGE AUTOMATIC assumed after "other=/dev/hda2"
Device 0x0300: Inconsistent partition table, 2nd entry
CHS address in PT: 616:0:1 --> LBA (9896040)
LBA address in PT: 9313920 --> CHS (579:195:1)
Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified
If not sure, first try IGNORE-TABLE (-P ignore)



It didnt do anyhting as im sure you know, I restarted the computer and it booted right into windows, no option for linux....... what should i try now?

CrashedAgain
01-20-2005, 04:24 AM
ok, lilo did have that boot=/dev/hda

so i typed sudo lilo in the terminal and this is what I got

knoppix@1[~]$ sudo lilo
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Warning: Unable to determine video adapter in use in the present system.
Warning: The boot sector and map file are on different disks.
Added Linux *
Added Linux(2.4)-1
Added Linux(2.6)-2
Warning: CHANGE AUTOMATIC assumed after "other=/dev/hda1"
Added Windows(hda1)
Warning: CHANGE AUTOMATIC assumed after "other=/dev/hda2"
Device 0x0300: Inconsistent partition table, 2nd entry
CHS address in PT: 616:0:1 --> LBA (9896040)
LBA address in PT: 9313920 --> CHS (579:195:1)
Fatal: Either FIX-TABLE or IGNORE-TABLE must be specified
If not sure, first try IGNORE-TABLE (-P ignore)

It didnt do anyhting as im sure you know, I restarted the computer and it booted right into windows, no option for linux....... what should i try now?

Oh-oh! I think maybe I'm over my head on this one. This is the second time recently I've seen posts about problems with device-mapper & no nothing about it.

But lets see what we can do.

First, It looks like lilo is OK until it gets to /dev/hda2. I think this is maybe your XP 'recovery' partition which doesn't need to be in lilo anyway, so just edit lilo.conf & delete the entry for /dev/hda2. Lilo will maybe then install OK.

This points out one of the bugs in the knoppix-installer, that is, if anything goes wrong with the lilo install the script just continues on with no message back to the user who will be left with a knopppix install which he(she) cannot boot into just as you have.

I don't think we have to be concerned about the FIX_TABLE warnings either, since they are about /dev/hda2 which is on your non-linux drive also.

The device-mapper I haven't a clue about, perhaps someone else can step in here??

gamezealot
01-20-2005, 05:06 AM
I finally got it to boot straight into linux.... i commented out these lines

other=/dev/hda1
label="Windows(hda1)"
other=/dev/hda2
label="WinXP/2K(hda2)"



I tried just doing this part first..... but it gave me an insane amount of errors when trying to load lilo

other=/dev/hda2
label="WinXP/2K(hda2)


NOW, since we know i can boot straight into linux....... I just cant boot back into windows without changing lilo back..... still need help here people.... this is what the end of lilo.conf looks like now

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the 'other' line to
# where your other OS' partition is.
#
# other=/dev/hda4
# label=HURD
# restricted
# alias=3
#other=/dev/hda1
# label="Windows(hda1)"
#other=/dev/hda2
# label="WinXP/2K(hda2)"

CrashedAgain
01-20-2005, 10:24 PM
I finally got it to boot straight into linux.... i commented out these lines

other=/dev/hda1
label="Windows(hda1)"
other=/dev/hda2
label="WinXP/2K(hda2)"



I tried just doing this part first..... but it gave me an insane amount of errors when trying to load lilo

other=/dev/hda2
label="WinXP/2K(hda2)


I would have thought just commenting out the other=/dev/hda2 part should have worked.
Try

other=/dev/hda1
label="WinXP"
table=/dev/hda

gamezealot
01-21-2005, 07:01 PM
ok, we have problems now....

- I try to edit lilo.conf when booted to the HD, and it brings up a blank document....
- I open it up while booted off the cd, it opens, but i cant make any changes, says I dont have write access or disk is full
- I'm doing all this while logged in as root.....

any ideas?

CrashedAgain
01-21-2005, 07:27 PM
ok, we have problems now....

- I try to edit lilo.conf when booted to the HD, and it brings up a blank document....
- I open it up while booted off the cd, it opens, but i cant make any changes, says I dont have write access or disk is full
- I'm doing all this while logged in as root.....

any ideas?

Browse to /etc with konqueror & see if there is a lilo.conf~ file, it is your backup file from the last edit. If not, copy the /etc/lilo.conf from the CD & edit it to what you had as close as you can.

gamezealot
01-21-2005, 08:43 PM
Got it.... boots into either windows or linux..... thanks for all the help guys