View Full Version : The kernel... Can I build my own?

01-25-2005, 01:38 AM
I just installed Knoppix 3.7 to my Hard Drive. Its running good, but I'm some issues....

If I boot with the default configuration, I can use my TV card (a hauppage winTV card). However, I cannot for the life of me get my Audigy to work.
I get the error "The module for your sound card, emu10k1.o, is not currently in your module search path". I'm pretty damn sure its in there, though. I looked.

But If I boot with the 2.6 kernel, the opposite is true, The Audigy is autodetected and used. But the TV card won't work. The channel scan always fails, even though I select the same configuration...

So, I'm wondering what I can do. This may very well become my main OS if I can get this little kink worked out.

It seems to me that the complete kernel sources are not included in the KNoppix HD install. Can I build a new kernel and install it? Does anyone have a link to instructions on how to do this that applies to Knoppix?

Any help will be appreciated.

01-25-2005, 10:27 AM
Can I build a new kernel and install it? Does anyone have a link to instructions on how to do this that applies to Knoppix?

Yes and yes.

Here's one: http://www.desktop-linux.net/debkernel.htm

Knoppix is based on debian, so there should be no problems.

01-27-2005, 01:49 AM
I followed those instructions to the letter, but once I got to make xconfig, I hit this error:

root@kevinsLINUX:/usr/src/linux# make xconfig
HOSTCC scripts/basic/fixdep
In file included from /usr/include/sys/socket.h:35,
from /usr/include/netinet/in.h:24,
from /usr/include/arpa/inet.h:23,
from scripts/basic/fixdep.c:115:
/usr/include/bits/socket.h:305:24: asm/socket.h: No such file or directory
make[1]: *** [scripts/basic/fixdep] Error 1
make: *** [scripts_basic] Error 2

Any ideas on what I should do now?

01-27-2005, 08:51 AM
Try with: apt-get install linux-kernel-headers

Did you also check the packages mentioned there as required?:
gcc (GNU C Compiler)
make (GNU make)

02-01-2005, 12:56 AM
I had same make problem this weekend, I had to add a symbolic link to the "asm-i386" directory in the /usr/src directory named "asm", a link to the /usr/src/linux folder did not work. I kept terrible notes and am at work now. A simple drag-n-drop from source folder, copy as link with a rename should work.

Once done, it took my Celeron 433 about 3 hours to complete.

No claims to ability or knowledge!

02-01-2005, 05:15 AM
Minor info update

refer to http://lkml.org/lkml/2004/4/4/83 about this topic

I checked what worked for me... assuming that you have a link to the kernel source location called linux

ln -s /usr/src/linux/include/asm-i386 /usr/src/linux/asm

11-30-2005, 07:40 AM
The same problem here!
Actually problem starts when we make a symbolic link to our new kernel source directory.

ln -s /usr/src/linux- /usr/src/linux

After doing this, make won't find kernel header files in /usr/src/linux/include/asm directory. So the solution to my problem was:

ln -s /usr/src/linux- /usr/src/linux-

And it works now!

Now what i wonder is here: According to this solution the make process uses new source kernel header files( in /usr/src/linux- Is it the right way or it should use the original kernel header files in /usr/scr/linux-2.6.12/include/asm