PDA

View Full Version : more problems with locales, help!



walla123ms
04-03-2003, 10:03 PM
Hello,
I'm new to the whole forum thing so I apolozige in advance if I'm doing something wrong or asking the wrong group... anyway here is my problem

I have installed Knoppix 3.2 on my sony laptop pcg-grv680 after having problems with RedHat 8.0 & 7.3 and it seems to work great! with a few minor exceptions... this one here being the big problem

I had a problem installing locales and tried several of the suggestions I read here including editing the /etc/locale.gen file. I tried to remove it too... I don't know when the actual problem I'm have now started but basically when I try to add a package it starts

Setting up locales (2.3.1-16) ...
Generating locales...
en_US.ISO-8859-1...

But it hangs here... It uses 99% of cpu and after several minutes I typed <cntr> C to stop it. I can't seem to configure it or remove it or install it or anything... Anyone know what I can do to fix or atleast get back to the problem where it does not work but does not hang forever? Thanks!

RockMumbles
04-03-2003, 10:15 PM
What does the following command output?

dpkg -l | grep locales

my debian woody system gives:

ii locales 2.2.5-11.2 GNU C Library: National Language (locale) da
note ii which basically means it's installed and configured correctly

Have you tried:

dpkg --configure -a

which will configure all non-configured packages.

HTH

rock

walla123ms
04-03-2003, 10:28 PM
dpkg -l | grep locales give me this

iF locales 2.3.1-16 GNU C Library: National Language (locale) da

if I type dpkg --configure -a I get this

root@walla123:/etc# dpkg --configure -a
Setting up locales (2.3.1-16) ...
Generating locales...
en_US.ISO-8859-1...

and that is where is sits.... forever.....

RockMumbles
04-03-2003, 10:33 PM
forever? what kind of processor (how fast of a machine?)

It takes quite a while to make the locales.

have you tried:

apt-get remove locales

that should only remove the one package.

rock

walla123ms
04-03-2003, 10:41 PM
okay, perhaps forever is a bit of an strech but this is a new 2.6 GHz machine and 7 mins of 99% cpu usage without any change is what I considered it hanging. Before when I was installing other stuff it would take about 1 min to get through about 30 different "en_US.ISO" things and then it would crash. Now it stops on the first one.

when I type this apt-get remove locales
I get
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
j2re1.3 limewire locales
0 packages upgraded, 0 newly installed, 3 to remove and 29 not upgraded.
3 packages not fully installed or removed.
and then I said yes and they were gone.
But if I want to do apt-get install limewire
It starts over and gets locales and were back to were back to the begining.

rickenbacherus
04-03-2003, 11:04 PM
You could always install from source- (it worked well for me anyway)if you get installed and working let me know because I can't get the software to connect to anything- tried the host list and a few other things.

walla123ms
04-03-2003, 11:18 PM
okay, I've gotten the source I think....

apt-get source locales
Reading Package Lists... Done
Building Dependency Tree... Done
Need to get 14.5MB of source archives.
Get:1 http://ftp.de.debian.org testing/main glibc 2.3.1-16 (dsc) [1573B]
Get:2 http://ftp.de.debian.org testing/main glibc 2.3.1-16 (tar) [12.8MB]
Get:3 http://ftp.de.debian.org testing/main glibc 2.3.1-16 (diff) [1685kB]
Fetched 14.5MB in 34s (415kB/s)
dpkg-source: extracting glibc in glibc-2.3.1

but what do I do to install? :oops:

RockMumbles
04-04-2003, 06:53 PM
Yesterday I did an apt-get upgrade on my 3.1 hd install and dpkg also exited with an error on locales, it's probably a debian problem.

I did a dpkg --configure -a and now I think I have everything but locales configured.

rock