PDA

View Full Version : klik on older knoppix versions



redss
01-26-2005, 02:43 PM
I have spent a lot of time creating a customized remaster of knoppix 3.4. For what I need, there is nothing that knoppix 3.7 offers that I can't get by installing into my knoppix 3.4 harddrive (used to create remaster images) and reburning the CD.... except klik....

Is there a way to upgrade my harddisk knoppix 3.4 to be compatable with the current version of klik that requires 3.7?

probono
01-26-2005, 03:38 PM
Klik supports Knoppix 3.7 and up. You might be able to get some apps to run using older Knoppix versions, but I would expect problems with most apps.

As a temporary, unsupported, inofficial workaround, you can add @2004-02-09 to any klik link, then it tries to be Knoppix 3.3+ compatible, e. g. klik://xvier@2004-02-09 - but that will only install software ftom 2004-02-09.

Greetings,
probono

redss
01-26-2005, 04:21 PM
I'd like to access the real klik, not the "@2004-02-09" version of klik.

A key feature of Debian is that so many packages can be upgraded easily via apt-get, thereby reducing the necessity of re-installing the OS with every new OS release. (Reinstalling is a lot of work for those of us who have customized & remastered an older version of knoppix)

That said, what is it in knoppix 3.7 that klik requires, and why can't a knoppix 3.4 install be upgraded with those dependencies?

I think its woth a try!

probono
01-26-2005, 06:25 PM
klik assumes that certain versions of certain libraries and applications are present on your base system. The more libaries are present in recent version in the base system, the less klik needs to download for each application. This is why klik will always work best with a recent version of Knoppix.

Currently, klik assumes that all packages are available in the version from Knoppix 3.7, or one of the other officially supported distributions (whatever is less).

Certainly, you can do a apt-get dist upgrade in order to bring your system to the newest status. If you make sure that you have the same packages installed as Knoppix, then there should be no problem in using klik.

Greetings,
probono

redss
01-26-2005, 07:13 PM
Ok so we're talking about 2 different sets of packages:
1) the packages that klik requires to run
2) the packages the the klikable app depends on

Which leads to 2 corresponding questions:

1) Other than the packages needed by the klikable app, are all the required package versions (that knoppix needs to run klik) on v3.4 ?

2) If all the packages (that a certain klik package needs) are updated to the same version as v3.7, then klik should work fine, right?

Whoops here's a 3rd question also
3) if a package version is older than what's on 3.7, does the klik install break, or will klik detect it and try to upgrade the outdated package?

Thanks, probono!

probono
01-26-2005, 07:46 PM
1) Other than the packages needed by the klikable app, are all the required package versions (that knoppix needs to run klik) on v3.4 ?
Yes.

2) If all the packages (that a certain klik package needs) are updated to the same version as v3.7, then klik should work fine, right?
Correct.

3) if a package version is older than what's on 3.7, does the klik install break, or will klik detect it and try to upgrade the outdated package?
No, because klik doesn't check what you have installed in your base system. It blindly assumes a set of packages that is stored on the server. klik tries to detect which distribution you are running and if your distribution is known to the klik server, then the server knows the correct list of packages it assumes to be present. If klik doesn't recognize your distribution, it assumes that the "least common denominator" of packages from the supported distributions is present in your base system.

Hope this helps.
Greetings,
probono