View Full Version : Error while writing knoppix with tohd

01-26-2005, 05:05 PM
I have a knoppix 3.4 cd and an old computer with a 2 gigabtyte harddisk.
A normal installation of knoppix isn`t possible with this so i tried a "poor man installation".

I formatted my harddisk this way:
hda1:1 GB linux ext2
hda2:0.5 GB linux swap
hda5:0.5 GB linux ext2

Now I tried to copy an image of the knoppix cd to /dev/hda1 with the tohd=/dev/hda1 command.
After a while i`ve got this error message:

/bin/cp: writing "cdrom 2/knoppix/knoppix:input/output error cloop: unloaded

Does anyone know what the problem is and how I could do better?

01-26-2005, 10:09 PM
well im Pretty suure it needs to be atlleast 2.5G to hold knoppix

01-26-2005, 10:59 PM
well im Pretty suure it needs to be atlleast 2.5G to hold knoppix

Maybe you mean a knoppix-installer style install, because the "tohd=" has never required more thatn 900Mb in my experience. It is, after all, writing only the compressed image from the CD.

Sounds like the original poster is having a hardware I/O problem -- my first instinct would be to think the CD wasn't burned properly. One time I burned the iso to a RW disk isntead of R, and it sort of resembled a working disk... but didn't really work! Maybe the iso was corrupted in the download.

01-27-2005, 09:28 AM
I don't think that's the case. My CD isn't burned, it's from a german computer magazine.
My problem is that I really can't afford a download of 700 MB.
If anyome has a solution I would be very grateful.