View Full Version : CoExisting with WINDOZE

A. Jorge Garcia
12-23-2002, 05:47 PM
OK, before you guys start flaming me, this is my better half's PC with a winmodem! She'll die if I get rid of WINDOZE....

Anyway, I ran knx-hdinstall and managed to kill the WINDOZE partition when trying to make new linux and linux swap partitions with cfdisk.

Question 1: Is there some way to repartition a HD to install KNOPPIX without killing the currently installed WINDOZE (single partition of whole drive)?

Also, I reinstalled everything as follows:
hda1 WIN FAT32 3000KB
hda2 linux swap 256KB
hda3 linux rest of drive.
I reinstalled WINDOZE and had it working before reinstalling KNOPPIX. Now I can't boot into WINDOZE. Only KNOPPIX shows up on the dual boot screen.

Question 2:How do I undo this? Is it an MBR problem? Now I have a great Debian install on the HD, but cannot boot WINDOZE! Should I not have used one of the last knx-hdinstall options for the MBR dual boot? Could I have used a boot disk to boot the Debian install on the HD when I want and just boot to WINDOZE otherwise?


12-23-2002, 06:40 PM
Don't panic there is a nice solution for this problem:

- Start debian

- Edit /etc/lilo.conf as root (Using vi or joe, or whatever you like)



to the end of it ...



(also as root)

Reboot and boot your Windows by selectiing it from the menu ...



12-23-2002, 09:31 PM
use "parted" or "nparted" (the later with a simpler interface) to repartition the drive. this works well with FAT partitions, NTFS beeing a problem.

Otherwise use one of the commercial partition mannagers to free some space on the disk.

A. Jorge Garcia
12-23-2002, 09:47 PM
Is "parted" freeware? I understand that the commercial program partitionmagic works well for this. I'd like to stick to open source or freeware.

Thanx, Fabian, I tried your fix and everything works fine!


12-24-2002, 05:49 PM
I used Partition Magic 5.0 in Win98 to partition first. No problems on install. Installed knoppix on hda 2 and had it boot from there also. Used Boot Magic as boot manager.

Only problem. I still can't get on the net using any type of linux since I reinstalled windoze. I have to wonder how this is possible.

I think the problem is in the eth0 setup.

Does anyone know how to put eth0 into 10 half duplex mode?