View Full Version : Problem installing gcc

01-28-2005, 04:58 PM
Hi everybody,

I am new member to this forum.

I have installed featherlinux on my hdd. It is a knoppix remaster so a debian derivative like knoppix. It includes tcc, tiny c compiler, but I need gcc.
I dont have internet on my linux pc so I downloaded .deb packages about 34 different files for gcc 3.5 and started installing with dpkg.

Now, I am facing a strancg dependency problem.

while installing g++-3.5--opere1-bla-bla.deb, it says it depends upon

libstdc++6-dev. and while installing libstdc++6-dev it complains about not having installed g++-3.5 !!!

I dont know much about debain packages but this is a deadlock I am facing.

Can anyboday suggest what do do to install gcc ?


01-30-2005, 05:42 PM
Try put all the .deb packages in a FOLDER THEN INSTall (damn caps lock) all at once with dpkg -i /<foldername>/*

02-01-2005, 12:35 PM

thanks ...that worked for me..
but now after installation it couldnt recognize gcc command.

I tried to compile a Hello World program with g++-3.5 but it stops at the error message

g++-3.5 hello.cpp
(after lisint some .h files.......)
linux/limits.h file or directory does not exists

do I need to install some other package ? I dont know what could be the problem?