PDA

View Full Version : I can't turn down the volume



will103
01-29-2005, 10:41 PM
Hi, I have a problem with the sound on my knoppix (hard drive install) system. I have attached a set of small speakers that do not have a volume control. The system volume is so high that it could damage my speakers but i can't find out how to turn it down. I have tried kmix but changing the settings there makes no difference.

Any ideas?

Thanks, will103

Markus
01-29-2005, 11:02 PM
Try alsamixer or:

aumix -v 50 -w 50
su
alsactl store

will103
01-31-2005, 10:52 PM
Try alsamixer or:

aumix -v 50 -w 50
su
alsactl store

Thanks for the suggestions Markus but they didn't work on my system.

Alsamixer
alsamixer: function snd_ctl_open failed for default: No such file or directory

Then tried
aumix -v 50 -w 50
aumix: MIXER_WRITE

alsactl store
bash: alsactl: command not found

Cheers

will103

Markus
02-01-2005, 07:05 PM
Hmm, I thought I already posted something to this topic today.
What does just running aumix say?

Are you using ALSA? Check what sound and snd_ modules are loaded with lsmod.

will103
02-01-2005, 09:18 PM
Hmm, I thought I already posted something to this topic today.
What does just running aumix say?

Are you using ALSA? Check what sound and snd_ modules are loaded with lsmod.

Hi Markus,

I am running OSS not ALSA.

I tried running lsmod but I cannot understand the output. Here it is

Module Size Used by Not tainted
radeon 108548 0
ipt_limit 1048 7 (autoclean)
iptable_mangle 2228 0 (unused)
ipt_LOG 3416 7
ipt_MASQUERADE 1528 0 (unused)
iptable_nat 17176 0 [ipt_MASQUERADE]
ipt_TOS 1144 0 (unused)
ipt_REJECT 3288 0 (unused)
ip_conntrack_irc 3088 0 (unused)
ip_conntrack_ftp 3888 0 (unused)
ipt_state 632 4
ip_conntrack 20648 2 [ipt_MASQUERADE iptable_nat ip_conntrack_irc ip_conntrack_ftp ipt_state]
iptable_filter 1768 1
ip_tables 11768 11 [ipt_limit iptable_mangle ipt_LOG ipt_MASQUERADE iptable_nat ipt_TOS ipt_REJECT ipt_state iptable_filter]
ntfs 50944 1 (autoclean)
parport_pc 25128 1 (autoclean)
lp 7460 0
parport 22496 1 [parport_pc lp]
nls_iso8859-1 2844 1
nls_cp437 4348 0 (unused)
autofs4 8756 1
af_packet 13544 0
i810_audio 25048 1
ac97_codec 11884 0 [i810_audio]
soundcore 3428 2 [i810_audio]
sis900 12428 1
crc32 2816 0 [sis900]
serial 52068 0 (unused)
mousedev 3832 1
hid 22564 0 (unused)
input 3168 0 [mousedev hid]
usb-storage 62016 0 (unused)
ataraid 6404 0 (unused)
ieee1394 183300 0
usb-ohci 18088 0 (unused)
usbcore 57824 1 [hid usb-storage usb-ohci]
pcmcia_core 39840 0
thermal 6692 0
processor 9008 0 [thermal]
fan 1600 0 (unused)
button 2700 0 (unused)
battery 5952 0
ac 1792 0
ide-scsi 9040 0
rtc 7004 0 (autoclean)
ext3 64388 1 (autoclean)
jbd 46804 1 (autoclean) [ext3]

When I run aumix all the levels are set for around half, but moving the sliders makes no difference to the volume of my speakers.

Thanks again for all of your help

will103

Markus
02-01-2005, 09:44 PM
Hmm, I haven't much used OSS. Too bad you've already installed while using the alsa cheatcode before installing generally gives a better sound system.
I didn't see the sound module so you might want to try with modprobe sound and see if you can tinker with any mixers from ll /usr/bin|grep mix or kmix after that. No need to try alsamixer or aumix with OSS. Also if you use KDE have a look in Control Center -> Sound & Multimedia -> Sound System, and check "enable the sound system" to see if kmix would work with arts.

EDIT: Come to think of it, you can get a potentiometer for less than 1 /$ or from any old scrapped piece of electronics. A bit of soldering and you have a volume control. (sorry for potentiometer being in swedish, I hope it's the same in english)

will103
02-01-2005, 10:36 PM
Thanks Markus. I'll give your suggestions a shot.

Next time I install Knoppix I think I'll use the ALSA cheatcode.

Cheers

will103