View Full Version : Newbie needs help: Errors when running knoppix-installer

02-02-2005, 04:53 PM
I wanted to try knoppix on my hard drive, but for some reason the knoppix-installer is giving me some problems.

First, right now I have the following partitions on my hard drive: 26GB NTFS for windows, and 4GB of unpartitioned space which I wanted to use to try out knoppix from the hard drive.

I tried the following both by using the standard kernel and the newer one by typing knoppix26:

1) from the terminal window, i typed "sudo knoppix-installer". A dialog comes up saying that I don't meet the requirements (but isn't 4GB enough for a standard installation?)
2) I typed "IGNORE_CHECK=1 sudo knoppix-installer". I start by selecting a "beginner" installation. But when I click Next, I get some error from Xdialog (I think) and the terminal window displays the help for the xdialog command?? The the installation quits.

After, I tried to reboot with the "knoppix 2" (text mode) option, and run "IGNORE_CHECK=1 sudo knoppix-installer" again. Still, after choosing the "beginner" installation, I would immediately get this:

Fatal dialog error:
Error: Expected at least 7 tokens for --radiolist, have 4.
Use --help to list options.

And the installation would abort.

Am I doing something wrong? Can anyone help? Thanks

02-06-2005, 01:06 AM
I'm no expert on this, but you may want to try partition before you try the installer. In the K menu in KDE, go to System=>Qtparted or type sudo qtparted in the shell. You'll want about 500MB as a linux swap partition, and 3GB for ext2 or ext3. Like I said, I'm probably talking out of my rectum.

02-12-2005, 12:41 AM
I have exactly the same problem... I always get the "don't meet requirement" dialog while I actually have an empty 6 GB space... If I continue to try to make partition, in the end I'll get error message "OPEN DISK READ-ONLY - YOU HAVE NO PERMITION TO WRITE"... and then... "FATAL ERROR CANNOT GET DISK SIZE".....

can someone help with this problem, cause I'm new to Linux and seems that I won't be able to solve this although I've spent like the whole day... =(