PDA

View Full Version : Nessus-Update-Plugins Troubleshooting (Hard Disk Install)



velvet
02-03-2005, 02:46 PM
I am pretty new to Knoppix, so this may be a lame newb question. Whenever I attempt a nessus-update-plugins (root), I get athe following error.

Open /var/lib/nessus/nessus/nessus_org.pem : No such file or directory

Anyone know how to correct this? I would like to be able to update my plugins.

Velvet

pureone
02-07-2005, 01:30 PM
apt-get update
apt-get remove nessus
apt-get install nessus
nessus-update-plugins

i just did a check on my pc and there is no /var/lib/nessus/nessus/ but there is a /var/lib/nessus were the plugins are kept.

helpdeskdan
02-16-2005, 04:07 PM
I'm using 3.7 and on 3.7, no amount of goofing I have done will make apt-get work right.

I tried getting nessus to work. Failed. Here's what I have tried:

Update script posted:
http://www.knoppix.net/forum/viewtopic.php?t=2805&view=previous

But, that doesn't work because nessus-update-plugins says I'm not root!!
(what the?! Su, root shell, nothing works! finger = no users logged on. Grumble. Try to turn on ssh so I can ssh localhost. Do NOT... NOT TRY TO ENABLE SSH SERVER, it is broken!!)

So, cp nessus-update-plugins ~, vi & comment out "exit" line and run from ~. It didn't seem to work quite correctly, I think the previous script posted in the forum needs to be updated. (also, to run it you need to adduser which means, you guessed it, more cp ~ and edit)

Any ideas?

Thanks,
-Dan