View Full Version : error when trying to insstall software with APT

02-05-2005, 04:06 AM

Installed Knoppix on my hard drive since it was the only distro that almost effortlesy recognized my wireless card.

The problem happen when I try to install software using APT.

I did APT-GET update then upgrade.

this is the result when I try to install Mozill Firefox.

below is sceen output...

root@maple:/home/nick# apt-get install mozilla-firefox
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
libpng12-0 libpng12-dev
Suggested packages:
mozilla-firefox-gnome-support latex-xft-fonts xprt-xprintorg
The following NEW packages will be installed:
The following packages will be upgraded:
libpng12-0 libpng12-dev
2 upgraded, 1 newly installed, 0 to remove and 444 not upgraded.
Need to get 9808kB of archives.
After unpacking 27.0MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.de.debian.org testing/main libpng12-dev 1.2.8rel-1 [245kB]
Get:2 http://ftp.de.debian.org testing/main libpng12-0 1.2.8rel-1 [115kB]
Get:3 http://ftp.de.debian.org testing/main mozilla-firefox 1.0+dfsg.1-2 [9448kB]
Fetched 9808kB in 1m11s (137kB/s)
(Reading database ... dpkg: error processing /var/cache/apt/archives/libpng12-dev_1.2.8rel-1_i386.deb (--unpack):
files list file for package `libgtk2.0-common' is missing final newline
Errors were encountered while processing:
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@maple:/home/nick# dfff -h
bash: dfff: command not found
root@maple:/home/nick# df -f
df: invalid option -- f
Try `df --help' for more information.

tried this to see if I had space left ....

root@maple:/home/nick# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda1 5.8G 2.3G 3.3G 41% /

I have no Idea what all this means. Anyne have any ideaas?


02-10-2005, 05:32 AM
Looks like a problem with the package from http://ftp.de.debian.org. Either it did not download properly or the package is broken. Try deleting the package /var/cache/apt/archives/libpng12-dev_1.2.8rel-1_i386.deb then redo the apt-get install command. If this does not work, try 'apt-get -t unstable install mozilla-firefox' (or apt-get -t stable install mozilla-firefox) to get a different package from unstable or stable instead of testing or change your sources list from 'http://ftp.de.debian.org' to 'http://ftp.debian.org' (edit /etc/apt/sources.list). Apt-get update again, of course.

02-14-2005, 09:56 AM
I have tried everything with apt-get that are mentioned in these forums :( but I still get the same error message

Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

frozen-bubble is removed but it is the frozen-bubble-data that breaks everything.

I've tried to install the stable, unstable, changed sources and tried the --purge command

I can't install anything because of this, please help :roll:

02-14-2005, 02:17 PM
Try this: http://www.knoppix.net/forum/viewtopic.php?p=49772 for frozen-bubble.
For libgtk2.0-common, just wait a day for it to get hopefully fixed.

09-10-2005, 06:58 PM
I was all set to start all over again for the millionth time when I came across this(taken me all day to find it mind). Thankyou and goodnight