View Full Version : Editing System files as 'root'

02-06-2005, 08:16 PM
I'm a totaly Linux- newbie and new in this forum, so please have mercy!
I just installed Knoppix 3.7 yesterday, because I found it pretty good. I put it on a separate HDD, cause I wanted to avoid any risks for my two NTFS-partitions.
Lilo installed, XP was still running, everything seems to work.
Today I wanted to edit some .conf files, because my epson scanner needs to be activated this way.
I realized, that I had to do this with root-access. For an old DOS-Nerd this is something completely new, so I spent several hours with searching for the right commands.
The .conf-file is owned by root so
This is what I tried:
I open the shell ("DOS-Box")
I type SU and the admins password
I try to start kwrite to navigate to the file and edit it
This is what appears:
pit@Peter:~$ su
root@Peter:/home/pit# kwrite /etc/sane.d/epson.conf
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
kwrite: cannot connect to X server :0.0

I hope it's just me being too silly for that, so please tell me what to do.


tom p
02-06-2005, 10:21 PM
well, your problem is, that the way you opened the root shell, you don't have the right to open any window manager programs ; but fortunatly there are several options how to go on:

* open another console window and issue a "xhost +localhost" command. You can now connect from the root console.
* open a root console from the KNOPPIX menu - it has the right to open window manager programs.
* from a console window connect via "ssh root@localhost" to your computer - this should enable a X11 tunnel, so that you
can use X11 programs. Works also for remote computers.
* use a text editor (such as vi, joe, emacs, ...) to edit the conf file.


02-08-2005, 05:02 PM
Hi Thomas,
thanks a lot, you made it!
After this I was able to edit everything.

Doesn't mean I know what I'm doing....but now I can learn from my mistakes ;-D

Many thanks

02-08-2005, 06:18 PM
You don't need an x11 session to edit a conf file. You can simply su, then edit the file by typing 'vi filename'
It's that simple. It will give you an error message on exit, but the file will still be written correctly.

02-08-2005, 06:27 PM
you can open the file manager as a super user.

click the k then system, more programs. it should be there if its not either do it in the console or look for it :D

02-08-2005, 06:30 PM
Hello again,
I just made my first scan, almost everything works fine.....unfortunately not really anything!
Infocenter detected my scanner (epson 2480), but kooka didn't!!!! No scan-prog did!!!

Then I remebered my first problem and I remebered what Tom said: "start console from the knoppix-menu..."
"sane-find-scanner" found the damn thing while the same command didn't from the "ordinary-console".
So I started kooka from root-console....and it finaly worked!!!

My problem is: this could never be the right way to get these things started, could ist?
Is there's something wrong with my boot-sequence? What have I done to deserve this.... ;-)

Please set me back on track again.


02-08-2005, 11:46 PM
Using a terminal editor such as vi will work but you may find terminal editors (especially vi) unfamiliar & prefer an X based editor. IMHO the best is 'Kate'.

There are a couple of ways to run X applications as root:

The first (as mentioned above) is first type 'xhost localhost' as user, you can then start x apps from root console.

You can also use kdesu from a terminal (logged in as user): eg 'kdesu konqueror' will start konqueror as root. To use kdesu you must first set a password for root, 'sudo passwd' will do that.

I have desktop start icons for konqueror-as-root & kate-as-root. These I just drag'n'drop copied the icons from the start menu to the desktop then edited the properties application to run to be 'kdesu kate' instead of just 'kate'.