View Full Version : Problem after Nvidia update...

02-09-2005, 02:25 PM

I'm pretty new in Linux.
I have installed Knoppix 3.7 on my HD and updated the nvidia driver to 6629.
After this update, i couldn't start the tetris game (Frozen Bubble). Before the update, the game had worked.
I also have problems to install tuxracer. when i enter "./configure" it tells me that there is no tcl found.

Can anyone post me a detailed decription about what to do?

Thanks in advance.

02-09-2005, 07:22 PM

How exactly did you "update" your nvidia drivers? apt-get install? Or, did you re-compile your kernel?

Not exactly sure, on the newer releases of Knoppix, but, when I was running v3.4, you had to compile the nvidia drivers into your kernel, it wasnt as easy as just apt-get 'ing them...

If you were running Kanotix ( this IS NOT a sales pitch, just factual data information :) ), but, with Kanotix, Kano has made install scripts that would do the "compiling" the kernel for you...

If you need information on the kernel compiling, I have maintained a document on the nvidia kernel installing process, and can supply, if needed. ( it is rather "dated" though, it has the source links for Knoppix v3.4, but, I am quite sure, they arent that hard to change for newer kernel sources and newer NVidia drivers )

Hope this helps,
Ms. Cuddles

02-09-2005, 11:14 PM
Hi Cuddles,

Thanks for you reply.
I updated the driver as it was written on the nvidia homepage with the command "sh NVIDIA-Linux-x86-1.0-6629-pkg1.run". The installer compiled a kernel interface for me because the pre-compiled kernel interface didn't match with my kernel (2.4.27). The installation was succesfull because i can now see the nvidia logo on startup screen. I also made the necessary changes in XF86Config. So, i don't understand why this frozen-bubble isn't working now?
As already said, i'm a bloody newbie in linux and perhaps this method wasn't the good one to update the driver, but then the kde wouldn't start or not? By the way, I also haven't installed an internet connection yet in Knoppix. Normally I'm a windows user so there are many things i have to learn with linux...

02-10-2005, 12:36 PM
Problem solved!!!
There was in fact a problem with the new nvidia driver, I needed to re-install it with the option "--force-tls=classic". Now the game works.

But the other problem with tuxracer isn't still solved. I don't really know how to install correctly these tcl libraries. Anybody here who could post me a "how to" for newbies?