View Full Version : Loading Linux........................ Takes forever

02-11-2005, 06:52 PM
When I'm booting from LILO on the MBR, the "Loading Linux" operation takes > 2 minutes. the dots just crawl across the screen and then it finally boots normally. Because of this it takes longer to boot from HDD than from CD. This is not right! :P

What's going on?

02-15-2005, 07:06 AM
i have simular problem when using knoppix 3.7 after installing it to my hardrive. cd for sure loads faster. also older versions of knoppix loaded faster when installed to harddisk. i dont have problem with the dots taking forever, but i do have lots of boot info, twice as much as usual when booting form CD..... older version looked exactly the same when booting from cd or harddisk.

02-15-2005, 02:59 PM
Funny, 3.7 is faster for me on hard disk...although, I have a pretty crappy machine - 300mhz, 160mb RAM - don't know how much that plays in.

hogrod: I saw this too, but only one time when I installed it using the third install option (in knoppix-installer), "Debian like" or something. If you install using the first (top) install option (something like "Multi-user with hw detection"), it looks like the CD booting, with hardware autodetection and all. Plus, this boots *way* faster than "debian like" on my computer.

Can't help foamrotreturns, though, sorry!

02-15-2005, 07:09 PM
you're right about the debian-like vs beginner install. beginner is much faster...
however, no matter which installation option I choose, it still takes way too long to load the kernel.

02-15-2005, 11:14 PM
ok cool, i have mine installed the third way "Debian like"..... my pc is a 1.2ghz P3 with 512mb of ram. i have two hardrives, the first is a 20gb with windows xp and knoppix, and second one is a storage 120gb drive. I am gonna try installing one of the other ways.

02-16-2005, 03:03 PM
I found this with a little googlin': http://lists.debian.org/debian-laptop/2004/10/msg00031.html
Seems to be having the exact same problem that you are (on debian)...and if you read the follow up, it shows that it worked for him!

I don't know anything about the lilo.conf file...the only time I messed with it, I had to end up re-installing Knoppix... :roll:

I did in fact mess with the lilo.conf a bit. My "compact" option was commented out by default by Knoppix, so all I had to do was delete the '#' in front of it. It even made it faster on my computer...no periods come up after Loading Linux.
I think the mistakes I made before was not being root and trying to mess with lilo.conf and run 'lilo'.

Just make sure you are root, edit /etc/lilo.conf (remove the # in front of "compact" if it's there) (I used the Joe editor, at the command line, without loading KDE)
Then after you're done with that, save changes, exit the editor, and run 'lilo' (no quotes). Should work - no problem.

02-18-2005, 12:28 AM
Trying that option right now...
YES!!!!!! It worked!! Thank you so much!
I don't know why all of my googlin' didn't turn that up...
I'm gonna go add this to my laptop model config info thread

02-18-2005, 03:17 PM
Awesome! Glad I could help.

I really got some valuable info out of this one too...what with the lilo.conf.

Mine gave me the option to boot linux with 3 different kernels (and I only care about 1)...and 2 different windows (only one was an actual operating system)...so, I got those cleaned out!

02-18-2005, 05:11 PM
Yep. same thing I did. I hated the 3 different boot options IN ADDITION to the WinXP boot option, so I cleared out the ones I don't use, and now it works fine. Now if I could only get a cool lookin lilo splash working....