PDA

View Full Version : post-HD install: apt-get dist-upgrade problems



12-24-2002, 01:46 AM
I was able to get Knoppix installed on my HD - - it's a heavenly thing.

I was then able to apt-get update/upgrade without problems.

Then I apt-get dist-upgrade and KONSOLE crashes with a:

"The application Konsole (konsole) crashed and caused the signal 11 (SIGSEGV)."

What's weird is that my root account's desktop had a konsole opened when I had logged out -- this one starts up just fine. Click on the icon or type it into a command line (from, say, rxvt) and it fails.

I'm really new to debian so I'm not sure if this is a KNOPPIX or DEBIAN issue. Any help is appreciated.

12-25-2002, 10:51 PM
I had the same problem, and can't fix it :(. I subsequently did an 'apt-get remove konsole' with the intent of reinstalling it, and that failed. I now must suffer with gnome-terminal (2.10), and greatly mourn the loss of my beloved konsole. If anyone has any suggestions as to how I can get it back, please post your ideas.

Guest
12-29-2002, 12:36 AM
first i got the following error with apt-get update:

Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing mule2-wnn (NewPackage)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

Could solve it by manually resizing the cache by adding the line

Apt::Cache-Limit "8388604";

to /etc/apt/apt.conf.

Now the update of the pkg-database worked fine, so i tried a

apt-get install xine-ui

it looked good, until after the download of all the related packages libc6 was to be updated.
An Error occured (something about a wrong dpkg, i can't remember) and now all efforts to install anything end with:

root@proton:~# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libc6
The following NEW packages will be installed:
libc6
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 packages not fully installed or removed.
Need to get 0B/3350kB of archives. After unpacking 13.0MB will be used.
Do you want to continue? [Y/n] y
E: Cannot get debconf version. Is debconf installed?
(Lese Datenbank ... 68 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke libc6 (aus .../libc6_2.2.5-14.3_i386.deb) ...
dpkg ist nicht als installiert vermerkt, kann nicht auf Epochen-Unterstützung prüfen!
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libc6_2.2.5-14.3_i386.deb (--unpack):
Unterprozess pre-installation script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libc6_2.2.5-14.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
:cry:

i'm quite new to debian (coming from rpm-based linux ;-/), so i would appreciate any suggestion!!
thx

basti

thewalkingman
12-29-2002, 12:53 AM
first i got the following error with apt-get update:

Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing mule2-wnn (NewPackage)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

Could solve it by manually resizing the cache by adding the line

Apt::Cache-Limit "8388604";

to /etc/apt/apt.conf.

Now the update of the pkg-database worked fine, so i tried a



Thanks for the help

the knoppix install has allot of bugs

tuxtom
01-22-2003, 11:58 AM
Then I apt-get dist-upgrade and KONSOLE crashes with a:

"The application Konsole (konsole) crashed and caused the signal 11 (SIGSEGV)."

I tried the same and got similar things.
Just an apt-get upgrade works excellently.

I tried a dist-upgrade after changing "testing" to "unstable" in /etc/apt/apt.conf. After changing of about 750 packages a had a working sid.
I think it's also possible to downgrade to woody by changing "testing" to "stable", but I didn't try.

Maybe for a pure dist-upgrade you have to to something in /etc/apt/sources.list.

tom

01-23-2003, 05:21 PM
I didn't do a dist-upgrade, just did an apt-get update; apt-get upgrade with the stock sources.list and just recently my konsole has been left in a non-operable state.

The error when you try to run konsole is:

Fontconfig error: Cannot load default config file
...

can anyone help?

TIA

rock