View Full Version : LTModem & Knoppix

04-05-2003, 02:59 AM
I have Knoppix 3.1 installed on a Toshiba laptop. KDE 'control centre' reports I/O 1080-1087 & 1400-14ff used by Lucent LT Winmodem so Knoppix has found the modem & it is one which is supposedto be supported by LTModem drivers. KPPP reports 'modem is busy' (doing what??) in /dev/ttyS1. I have downloaded ltmodem-2.4.20-8.26a9_i386.deb & 'installed' it using KPackage & it has produced /lib/modules/2.4.20/lt_modem.o & /lt.serial.o but it doesn't seem to have helped connect to the modem. Documentation which comes with the package doesn't help, it just says run ./ltinst2. There is no /ltinst2 anywhere. So I have downloaded ltmodem-8.26a9 package & opened it. It has an /ltinst, a /build_module and a /build_deb . Trying to run any of them returns 'permission denied'. How am I denied permission? I am root. I thought root could do anything.
What am I doing wrong?

04-05-2003, 04:04 AM
ltinst2 is probably not executable, so you will have to make the file executable with a command like:

chmod a+x ltinst2

This command will change the executable permissions to allow all users to execute it. This assumes ltinst2 is in your current directory, then you can execute it with ./ltinst2


04-05-2003, 04:32 AM
Ok, I tried that. still permission denied.
Has anybody out there actually gotten a winmodem working? How did you do it?

04-05-2003, 04:38 PM
I have'nt got it to work with Knoppix, but in any other distro I got the package and built the drivers. It goes thru a pile of checks and builds for your system.

Your problem may be the symbolic link of /dev/ttyLT0 /dev/modem but using the package it will create the link.

I found with Knoppix tho that I got a kernel mismatch problem and have'nt tried again yet.


04-05-2003, 08:01 PM
Using the package??? My problem is how do you 'use the package'. I've 'installed' it with KPackage, looked for any instructions, tried to follow the instructions (e.g. run the non-existant ./ltinst) searched for more instructions, searched this forum for winmodem & ltmodem & not found anyone who successfully installed it & I'm all out of ideas. What do I try next?

04-05-2003, 10:50 PM
I have'nt checked the LTmodem site in a long time but there should be a .tgz or .bz2 file on it. Thats what I use, use Midnight Commander to extract the files then cd into the directory & run ./build module.
Not dead sure on that, I'm not on that machine, but you'll see all the files, ./ltinst is in there.


04-06-2003, 05:20 PM
I can't believe it! I actually got it to work! I had already DL'd the ...tar file & extracted it some time ago but the ./ltinst wouldn't run ('permission denied' see above). I have NO idea why. Anyway, I re-copied the ...tar to /root, extracted it there & everything seems to have run through ok. ./ltinst2 is made by build_module & doesn't appear unless build_module is successful. Anyway, so far so good, I hope. Thanks for the help.

04-14-2003, 06:46 AM
I can't believe it! I actually got it to work! Your Winmodem really works now? Could you please share with us so that we can Winmodems too?

04-16-2003, 02:51 AM
Maybe you weren't able to run the script because the partition where it was located was mounted as "noexec", so there wouldn't be any way you could make it run.

04-22-2003, 01:40 AM
I should have found this thread before posting a new one...
Anyway, can you please see my message at the Lounge thread?
"Lucent winmodem may work with KNOPPIX CD".
Anyone else who was successful in getting ltmodem to work, please make us know!

(please note the BIOS fine-tuning, especially when the modem is ONBOARD)