View Full Version : CDROM not recognised/opening after install

Victor Warner
02-13-2005, 11:27 AM
I have a CD with Knoppix 3.4. Booting and running from the CD went/is fine. Can look and access files from the CD. The computer is a DELL Latitude 510/610. The CD is a removable.

Then did a harddisk install (sudo knoppix-installer). This also appeared to go fine. The computer then booted from hard disk with Knoppix.

However, whether logged in as root or as a user cannot access the CDThere is an icon on the desktop and it shows under Konqueror/devices.

From Konqueror/devices get the following message

"Mount:Special device /dev/cdrom does not exist. Please check that disk is entered correctly"

Also under Konqueror/devices have tried mounting drive and got the above message. Also eject fails.

Any help with this would be greatly appreciated.

Victor Warner

When clicking on desktop icon get the following message:

"Unable to run command specified. The file or folder file:/mnt/cdrom does not exist.

02-14-2005, 09:22 AM
When clicking on desktop icon get the following message:

"Unable to run command specified. The file or folder file:/mnt/cdrom does not exist.

Follow the following steps: -
1. Delete the shortcut of CDROM from the desktop.
2. Right click on the desktop, click on new and then CDROM.
3. Change the name to whatever you like, click on device tab, select "/dev/cdrom".
4. Click finish.

Try it.

Actually what happens that the link to CDROM on the desktop are to /mnt/cdrom directory, which in turn is a link to /mnt/auto/cdrom. But when the knoppix is installed on harddisk the mount point for the cdrom is at "/cdrom" ...8)

If unsuccessful try giving the command "mount /cdrom" at the command prompt....

Post the results... :wink:

02-14-2005, 09:54 AM
First check your fs table to see whether the hd install made an entry for the CD drive. You don't have to be su to do this, just open a terminal window and type cat /etc/fstab or, if you have lots of partitions and hardware, less /etc/fstab (When you're done looking, close less by typing q)

Look for a line that starts out /dev/cdrom - there may also be others that start /dev/dvd and /dev/cdrom-something-else

If you see /dev/cdrom /cdrom iso9660 etcetera (which is how Knoppix set mine up) then that's the problem. Your CD drive isn't at /mnt/cdrom like it might be in other Linux distributions, it's at /cdrom.

If that's the problem, there are different ways to fix it. You can make applications look for the drive where Knoppix decided to mount it for you, or you can change where the thing mounts when you boot.

It's probably easiest to edit /etc/fstab so that the drive is where applications are looking for it. First, from here on, you'll need superpowers, so either su or be prepared to start every command with sudo

Then, to be on the safe side, make a copy of the file sorta like this: cp /etc/fstab /etc/fstab.bak Then open /etc/fstab and change the line /dev/cdrom /cdrom etcetera to /dev/cdrom /mnt/cdrom etcetera

When you're done editing, make sure /mnt/cdrom exists with ls /mnt/cdrom - if it's not there then mkdir /mnt/cdrom.

Just editing /etc/fstab doesn't make anything change until the system reads the file again, such as the next time you boot. There's a way to force it to be re-read, but if your cdrom line has the same options that mine does, then that won't work (unless you feel like editing the options, too).

Instead, just unmount the drive with umount /dev/cdrom and then remount it as type iso9660 with mount -t iso9660 /dev/cdrom /mnt/cdrom and you're done. Remember that you're still superuser, if you are, and decide whether to keep wearing that funny outfit or to change out of it by typing exit or ctrl-d

Now on the other hand ... maybe the hd install didn't write a line to your /etc/fstab for some bizarre reason. In that case, all it takes for a temporary fix is to use the mount command as before, and for a permanent fix add a line to /etc/fstab.

If you have to add the line, and you're not familiar with the options that typically go with cdroms, read the manual for the mount command by typing man mount (because man fstab is fairly useless) and write back to the forum. We'll fill you in on what Knoppix uses by default and why.

Good luck!

-- Ed

02-14-2005, 10:50 AM
Or you can do what raj1478 says. :D I apologize, I was booted into Morphix when I wrote my first reply, and I didn't look closely enough at my Knoppix partition. Bad geek.

When I booted into Knoppix, I found I had a different problem. My /etc/fstab says /dev/cdrom /mnt/auto/cdrom ... which doesn't exist.

So if what raj1478 says doesn't work, tell us what the /dev/cdrom line says in your /etc/fstab.

-- Ed

Victor Warner
02-14-2005, 11:28 PM
raj1478 and Ed,

Thank you both for your replies. As suggested I followed raj1478 suggestion (including runing the mount /cdrom command). But after do so I get the following message:

"Could not mount device. The reported error was: mount: special device /dev/cdrom does not exist"

The fstab file reads:

# /etc/fstab: filesystem table.
# filesystem mountpoint type options dump pass
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda3 /mnt/hda3 vfat noauto,users,exec,umask=000 0 0

I can see there are 2 entries for the CDROM but was not sure want to edit or delete.

Victor Warner[/quote]

02-15-2005, 07:41 AM
Aha. Yes. Mmmhmmm. Quick Watson, summon Sherlock Holmes!

Here's what I suspect - in fact, what I see in my own installation: Things Which Should Exist But Don't.

Try this: get an expanded directory listing for the relevant items: /dev/dvd, /dev/cdrom, /dvd, and /cdrom. That is, open a terminal window (don't need to sudo) and ls -l /dev/dvd and ls -l /dev/cdrom, and so on.

The ls -l command shows not just whether they exist, but also if they're symlinks - symbolic links, something rather like an enhanced version of a Windows shortcut. Symlinks stand out by having a lower-case L as the first letter on the line, and then at the end of the line the entry you're looking at has an arrow (->) that points to somewhere else.

If you find those, also do ls -l other-place

Each result should be one of 5 possibilities:

- if it doesn't exist, you'll get an error message
- if it's a directory, but empty, a message like total:0
- if it's a directory, not empty, the contents
- if it's a non-linked thing, the listing shows a regular entry with the thing at the right end of the line
- if it's a linked thing, you'll see that arrow

What you're looking for is things mentioned in /etc/fstab that don't actually exist, or things that are symlinked to something else that doesn't exist. In those cases, just changing the desktop shortcut won't fix the problem.

Keep us posted! And especially, if you get to feeling this is all a bit too much ummm, excitement thankyouverymuch, don't just walk away from Linux. There are other varieties that will surely be smoother. Let us know, okay?

-- Ed

02-15-2005, 09:15 AM
"Could not mount device. The reported error was: mount: special device /dev/cdrom does not exist"

I'm interested in knowing whether you have DVD drive or a CDROM Drive? What type of CD are you putting in the drive? A CDROM or DVD ROM?

The commands suggested above will help. I'll prefer you to give the following commands and post the result: -

1. ls -l /dev/cdrom
2. ls -l /dev/dvd

# /etc/fstab: filesystem table.
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0

As I can see there are two entries in the fstab file. Try to follow the steps to make a new DVD ROM icon on the desktop, just to try something different and post the results.

Good Luck..

Victor Warner
02-15-2005, 10:47 AM
raj1478 and Ed

Thank you for your further messages.

Here is the result of the ls command

sh-2.05b$ ls -l /dev/cdrom
ls: /dev/cdrom: No such file or directory
sh-2.05b$ ls -l /dev/dvd
lrwxrwxrwx 1 root root 10 Feb 12 14:01 /dev/dvd -> /dev/cdrom

I tried creating new DVD ROM but the error message was still the same (and tried several combinations

I have a CDROM, and I have tried different types of CDs, data CDs (such as original CDs provided by software suppliers, homemade one's) and original audio CDs. None of which I could access.

Victor Warner[/quote]

02-15-2005, 11:14 AM
sh-2.05b$ ls -l /dev/cdrom
ls: /dev/cdrom: No such file or directory
sh-2.05b$ ls -l /dev/dvd
lrwxrwxrwx 1 root root 10 Feb 12 14:01 /dev/dvd -> /dev/cdrom

There is the problem. You don't have the cdrom device in your /dev directory, and the symlink /dev/dvd is also pointing to it, that is why the second option of DVD icon is also not working.

The solutions to problem are a few: -

If I'm correct then there is file named MAKEDEV or MKDEVICE or something like this in the /dev directory. Try executing "<watever name you find> /dev/cdrom" and try again to mount the CDROM.

If unsuccessful then try to execute the command "MAKEDEV" without any arguments.

Post the results...

Victor Warner
02-15-2005, 11:56 AM

Thank you for message

In Konsole (as root) I typed the following as suggested and got the following results

root@DELL:/dev# MAKEDEV /dev/cdrom
/sbin/MAKEDEV: don't know how to make device "/dev/cdrom"

root@DELL:/dev# MAKEDEV

I trried creating a new CD ROM device but still got the same error message

Victor Warner

02-16-2005, 01:15 AM
Before running the MAKEDEV script to try fixing the mess made by Knoppix-installer, let's see whether Linux knows that you have a CD drive and where it really put it (as opposed to all the misleading clues about its location from Knoppix-installer).

Information about hardware detection is in the text that flies by during boot-up. It should still be there on your system.

If you have a scrolling terminal, type

$ dmesg

If your terminal doesn't scroll, type

$ dmesg|less

Look for a description of your drive, probably near the bottom of everything. You should see Vendor, Model, Rev., Type.... If you can't find this at all, then Linux doesn't even know the drive exists. But since this is Knoppix, it most probably was found.

There might be a line like this (reading from my dmesg)

> sr0: scsi3-mmc drive: 40x/40x writer cd/rw et cetera

Then maybe a line like this:

> Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0

If so, congratulations! Your drive is at /dev/sr0.

Then when I type

$ ln -l /dev/sr*

I see that /dev/sr0 is symlinked -> scd0

Then I type

$ ln -l /dev/scd*

and see that yes, /dev/scd0 really exists. So I can call it /dev/sr0 or I can call it /dev/scd0, but now this command (sudo or su to root) really and truly makes my CD drive work:

# mount -t iso9660 /dev/sr0 /cdrom

If you find that your CD drive was autodetected, and that the mount command works, then edit that line in your /etc/fstab file.

> /dev/cdrom

> /dev/whatever

This will take effect the next time you boot.

-- Ed

02-16-2005, 06:58 AM
If your CDROM is working well in windows, then just follow the steps:
1. cd /dev
2. ls -l /dev/scd*
3. If there are scd0 or scd1 etc. listed and your CDROM is Secondary Master then
2. ln -s /dev/scd0 cdrom

Then try to mount to the CDROM...

02-16-2005, 08:50 AM
Tangential advice: if you know how to fish, teach others. Then they can feed themselves - and teach even more people - rather than coming back again and again for more fish.

-- Ed

02-16-2005, 09:27 AM
Final advice: if you know how to fish, teach others. That way they can feed themselves - and teach even more people - rather than coming back again and again for more fish.

-- Ed
I couldn't understnd the meaning of this post...

Please clarify...

Victor Warner
02-17-2005, 09:13 AM
raj1478 and Ed

Thanks again. I tried what you both suggested.

Using dmesg, I did the same message as Ed (Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0)

I typed "mount -t iso9660 /dev /sr0 /cdrom"

But I got this message in return:

mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
or too many mounted file systems

From this I am not sure what if anything I need to change in the fstab file.

I would be grateful to know what the next step is...

Victor Warner

02-17-2005, 09:20 AM
Thanks again. I tried what you both suggested.

Victor Warner[/quote]
Hi, I've seen in my knoppix harddisk-install that /dev/cdrom is a symbolic link to /dev/scd0, that is why I'd suggested you to give the command "ln -s /dev/scd0 cdrom" in the "/dev" directory. Had you tried it?

If yes then simply type "mount /cdrom" at the prompt or click on the CDROM icon you created.

Post the results...

02-17-2005, 12:25 PM
Victor, knoppix-installer sprayed so many different references to the CD drive around, and we've been hacking against it so long, that two possibilities come to mind:

- the latest attempt conflicts with something k-i put in place;

- something you did earlier in the session already tied up the drive.

These could have happened either on the /dev side of things or with the mount point (/cdrom, /mnt/cdrom, etc.).

Also, k-i did something just enough different in my case that what worked for me might not work for you. (It gave me two entries for CD-ROM drives in /etc/fstab as well as a third for a DVD drive - all for one physical unit - and the CD drives were mounted to nonexistant points in /mnt/auto.)

If adding another link doesn't work, you could try:

- unmounting (umount) the drive before trying to mount it again - you can specify the /dev view of it or the mount-point view;

- rebooting to clear out any temporary silliness that may have happened;

- manually going through and deleting the extra, useless directory entries - first on the mount side of things (/mnt/cdrom etc.) and then, if desperate, in /dev.

-- Ed

Victor Warner
02-18-2005, 10:55 AM
I am still no further forward


I did type in "ln -s /dev/scd0 cdrom": I got this reply:

I then typed in "mount/cdrom" and then got this reply:

[quote]mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

Ed: I tried what you suggested (as far as I understood it) but still no go.

What I am not clear exactly what (and exactly where) I should be deleting things.

Victor Warner

02-19-2005, 05:29 AM
Check your boot parameters and post them. The parameters can be found in "/etc/lilo.conf" or "/boot/grub/grub.conf" depending upon whether you are using "lilo" or "grub" as boot loader.

Is this CDROM doing well in Windows? There is an entry of DVD drive in your "fstab" file. Do you have DVD drive or combo drive? If yes, where is it connected?

Victor Warner
02-19-2005, 10:03 AM

1. It is a CDROM and not a DVDROM
2. The CDROM does perform well in Windows (Win2k)
3. Since there is a no DVDROM should I be deleting the reference to the DVD drive in the fstab file

Below is the lilo.conf file and the fstab file

Victor Warner


# /etc/lilo.conf - See: 'lilo(8)' and 'lilo.conf(5)',
# --------------- 'install-mbr(8)', '/usr/share/doc/lilo/',
# and '/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# | !! Reminder !! |
# | |
# | Don't forget to run 'lilo' after you make changes to this |
# | conffile, '/boot/bootmess.txt', or install a new kernel. The |
# | computer will most likely fail to boot if a kernel-image |
# | post-install script or you don't remember to run 'lilo'. |
# | |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
# bios=0x81

# bios=0x80

# Specifies the boot device. This is where Lilo installs its boot
# block. It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. ('/')

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller. Using 'compact' is especially recommended when
# booting from a floppy disk. It is disabled here by default
# because it doesn't always work.
# compact

# Default menu for Debian. (Using the images from debian-bootscreen)
# from Philipp Wolfer <phil@newswriter.org>.

# Install the specified file as the new boot sector.
# LILO supports built in boot sectory, you only need
# to specify the type, choose one from 'text', 'menu' or 'bitmap'.
# new: install=bmp old: install=/boot/boot-bmp.b
# new: install=text old: install=/boot/boot-text.b
# new: install=menu old: install=/boot/boot-menu.b or boot.b
# default: 'menu' is default, unless you have a bitmap= line
# Note: install=bmp must be used to see the bitmap menu.
# install=menu
# install=bmp

# Specifies the number of _tenths_ of a second LILO should
# wait before booting the first image. LILO
# doesn't wait if DELAY is omitted or if DELAY is set to zero.


# Prompt to use certaing image. If prompt is specified without timeout,
# boot will not take place unless you hit RETURN

# Specifies the location of the map file. If MAP is
# omitted, a file /boot/map is used.

# Specifies the VGA text mode that should be selected when
# booting. The following values are recognized (case is ignored):
# NORMAL select normal 80x25 text mode.
# EXTENDED select 80x50 text mode. The word EXTENDED can be
# abbreviated to EXT.
# ASK stop and ask for user input (at boot time).
# <number> use the corresponding text mode. A list of available modes
# can be obtained by booting with vga=ask and pressing [Enter].

# You can set a password here, and uncomment the 'restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration. If a
# command line is given, other than one specified by an 'append'
# statement in 'lilo.conf', the password will be required, but a
# standard default boot will not require one.
# This will, for instance, prevent anyone with access to the
# console from booting with something like 'Linux init=/bin/sh',
# and thus becoming 'root' without proper authorization.
# Note that if you really need this type of security, you will
# likely also want to use 'install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well. Please RTFM 'install-mbr(8)'.
# password=tatercounter2000

# You can put a customized boot message up if you like. If you use
# 'prompt', and this computer may need to reboot unattended, you
# must specify a 'timeout', or it will sit there forever waiting
# for a keypress. 'single-key' goes with the 'alias' lines in the
# 'image' configurations below. eg: You can press '1' to boot
# 'Linux', '2' to boot 'LinuxOLD', if you uncomment the 'alias'.
# message=/boot/bootmess.txt
# prompt
# single-key
# delay=100
# timeout=100

# Kernel command line options that apply to all installed images go
# here. See: The 'boot-prompt-HOWO' and 'kernel-parameters.txt' in
# the Linux kernel 'Documentation' directory.
# append=""
# Boot up Linux by default.

append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet"
append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet"

append="ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet"

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the 'other' line to
# where your other OS' partition is.
# other=/dev/hda4
# label=HURD
# restricted
# alias=3


# /etc/fstab: filesystem table.
# filesystem mountpoint type options dump pass
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda3 /mnt/hda3 vfat noauto,users,exec,umask=000 0 0

02-19-2005, 10:25 AM
Victor, I'm sorry I couldn't get back to you last night. I know it's frustrating to try a couple of things, then wait a day, try a couple of things, wait two days....

Knoppix-installer made four entries in my /etc/fstab: 3 CD (1 audio) and 1 DVD, for a single CD/DVD drive. No other Linux has given me four. So that's a known quirk.

I suspect one of the problems is the transition from 3.4 to 3.6 kernels - 3.4 has one way of dealing with CD drives, and 3.6 adds another, and Knoppix lets you choose either kernel. So extra entries in /etc/fstab and /mnt may be there to cover all the possibilities. And to add confusion!

It might help to know which kernel is running. Find out with

$ uname -r

The uname command tells you a few tidbits about your system. Usa -a to see all the tidbits (none of the others should be relevant right now) and -h to see what all the pieces are.

And yes, knowing that the drive is working in another environment is important diagnostic info. I'm sorry, I forgot whether you know where it's physically wired in your computer. Are there other optical drives?

When the computer first powers on, the BIOS looks for drives and (by default, anyway) displays what it sees. The bootloader has to start with what the BIOS tells it, so if you have to troubleshoot back to that point, check the BIOS printout. It includes four IDE slots:
- primary master
- primary slave
- secondary master
- secondary slaveIf you have one hard drive and one CD (that isn't a true SCSI drive), the standard places for them are HD at primary master and CD at secondary master. I've seen screwy setups, though.

To investigate the mount errors, it will help to know all the identities that Linux has assigned that one drive. If it's in the secondary master position, it might be known as some variation on hdc.

Knoppix gave me all of these mount points for one drive:
- /cdaudio
- /cdrom
- /dvd
- /mnt/cdaudio
- /mnt/cdrom -> /mnt/auto/cdrom
- /mnt/cdromhdc -> /mnt/auto/cdromhdc
- /mnt/dvd
- /mnt/sr0Note that the link targets /mnt/auto/cdrom and /mnt/auto/cdromhdc don't actually exist on my system!

Putting mount points in the root directory is an annoying thing that Debian does. The sr* name is sometimes given to IDE CD drives.

It would also help to know all the device names that Linux is batting around internally. This isn't really possible, though, because by default Linux populates /dev with billions and billions of entries that might possibly be needed some day under one of the infinitely many situations where it gets installed.

But we can see what's been symlinked to what. To get a shorter list (that will include stuff besides your CD), type this:

$ ls -l /etc | grep "lr"

Here we're taking the output of ls and piping it to grep, which pulls out only the lines containing lr (like symlink lines, which start with those two characters).

You might see, as I did:
- cdaudio -> /dev/cdrom
- cdrom -> /dev/hdc
- cdromhdc -> scdhdc
- dvd -> /dev/cdrom
- sr0 -> scd0 ... and so on through sr16 -> scd16By themselves these lists of mount points and devices probably aren't useful - except to show that no attempt was made to organize the setup, and so users get to hunt all over the countryside to solve problems. Still, my symlinks that go off into the bit bucket are harmless ... unless Linux is trying to use them!

Now when you get hardware errors you can check what's where by running the commands on the spot. For example,

# ln -s /dev/scd0 cdrom tells you

file exists - but what does that mean?

What the command tries to do is create a new entry (file) in whatever directory you're in. You want this new entry to be called cdrom and to link symbolically to /dev/scd0.

An entry for /dev/scd0 must already exist to create the link, so the error isn't about /dev/scd0 itself.

Is the command telling you that there already is an entry called cdrom in the whatever directory? Is that right? Is it already a symlink to something else?

When you typed

# mount /cdrom

you got a very useless error message. By not specifying both the device and the mount point, you're telling the mount command to go look in /etc/fstab for the other piece.

But something's wrong - see what's actually mounted where with

$ mount

Is something else paired up with /cdrom or /dev/cdrom? What? Where? Are there symlinks that go out into space somewhere?

I'm sorry you're having a problem that's taking so long to track down. I hope I've given you some ideas and tools for looking into this one, but also into other hardware problems that may come up.

Let us know, okay?

-- Ed

02-19-2005, 10:39 AM
Heh - you sneaked in a post while I was writing mine.

I'd say to delete the DVD line from /etc/fstab - it's not doing any good and may be causing this evil. Look for symlinks involving /dev/cdrom, /dev/dvd, /cdrom, and /dvd.

Is sda1 a USB device? If it's working, I'd also clean out the lines "#Added by Knoppix" - if they aren't working, you want to know who to blame, but if they are, then these particular comments are clutter.

-- Ed

Victor Warner
02-19-2005, 01:32 PM

Thank you for your detailed replies.

This is the information I got trying to implement what you wrote:

uname -r 2.4.26

uname -a Linux DELL 2.4.26 #1 SMP Sa Apr 17 19:33:42 CEST 2004 i686 GNU/Linux

uname -h comes up as an invalid option

ls -l /etc | grep "lr"
lrwxrwxrwx 1 root root 19 Feb 12 14:01 auto.ftpfs -> /usr/bin/auto.ftpfs
lrwxrwxrwx 1 root root 19 Feb 12 14:01 auto.sshfs -> /usr/bin/auto.sshfs
lrwxrwxrwx 1 root root 10 Feb 12 14:01 init -> /sbin/init

This seems rather different from the list you produced...

ln -s /dev /scd0 cdrom ln: `cdrom': File exists

/dev/hda1 on / type ext3 (rw,errors=remount-ro)
/dev/root.old on /initrd type ext2 (rw)
proc on /proc type proc (rw)
/dev/pts on /dev/pts type devpts (rw)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
automount(pid389) on /mnt/auto type autofs (rw,fd=4,pgrp=389,minproto=2,maxproto=4)
/dev/hda3 on /mnt/hda3 type vfat (rw)
/dev/sda1 on /mnt/sda1 type vfat (rw)

I deleted the entry for the DVD and for the entries for "Added by Knoppix" (in fact by commenting these lines out), so that fstab now reads:

# /etc/fstab: filesystem table.
# filesystem mountpoint type options dump pass
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# /dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
# /dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
# /dev/hda2 none swap defaults 0 0
# Added by KNOPPIX
# /dev/hda3 /mnt/hda3 vfat noauto,users,exec,umask=000 0 0

This is for a USB device and connecting a portable hard-disk/portable music player is recognised as such and I can see the files contained on it.

I am new to Linux so some of what you wrote is still new/unfamiliar.

Victor Warner

02-19-2005, 05:40 PM
This is a bug in Knoppix 3.4 that was fixed by version 3.6.
See this: http://www.knoppix.net/forum/viewtopic.php?t=13601
This fix was for a Knoppix-style install which uses the startup script /etc/init.d/knoppix-autoconfig.

For Debian style install which doesn't reconfigure the whole system with each boot I think all you should have to do is 'ln -s /dev/scd0 /dev/cdrom'. You're already on this track but it has to be 'ln -s /dev/scd0 /dev/cdrom' not 'ln -s /dev/scd0cdrom'. If for some reason /dev/cdrom already exists delete it then recreate it as a link to /dev/scd0.

Here's another couple of bugfixes for Knoppix 3.4:

You will get an error about bdflush during the startup. It doesn't affect anything but it's annoying. Here's the fix:

Comment out this line in checkroot.sh init script:

(line 35)

vi /etc/init.d/checkroot.sh
#[ -x /sbin/update ] && update <--- you add # at the start of this line.

If you have a wheel mouse, you have to change the protocol in /etc/X11/XF86Config-4 from 'auto' to 'IMPS/2':

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2"

To get your system sounds to work:

using arts:
Make sure volumes in Kmix are turned up, you need at least master and PCM turned up
KDE controlcenter->enable sounds;turn on system notifications
/home/user/.KDE/share/config/knotifyrc->set all to true
configure konqueror->plugins->plugins; enable pipe plugin sounds through arts

One of the reasons I switched to Kanotix is that it didn't have so many little bugs like these. Some of these are still in later versions of Knoppix.

02-20-2005, 12:46 AM
My CD/DVD was dead after installing 3.7 to hard drive this week, so something's still horribly wrong. It may be due to getting ready to try to support non-emulated mode for CDs, new to kernel 3.6.

One of the crazy things knoppix-installer did was create /dev/cdromhdc and a symlink to /mnt/auto/cdromhdc. You can see the logic of it, but that's in addition to other mount points like /cdrom and /mnt/cdrom. And /mnt/auto has nothing in it.

I fixed mine, but we're still working on Victor's.

-- Ed

02-20-2005, 06:37 AM
... transition from 3.4 to 3.6 kernels....
:oops: Ummm ... of course I meant 2.4 to 2.6. I doubt I'll be alive when Debian is ready to release 3.6. :wink:

uname -h comes up as an invalid option
Why, yes. Clearly I meant uname --help (With two dashes. Ahem. :))

Here's why I made that mistake: Linux commands often can be followed by an argument. Sometimes it's one dash and one letter, sometimes it's two dashes and the whole word, and sometimes either one works. Usually it's not one way with some arguments and the other way with others when there are so few of them.

This seems rather different from the list you produced...
Okay, I'll say it: Just Shoot Me. Try running the command against your /dev directory:

$ ls -l /dev | grep "lr"

automount(pid389) on /mnt/auto type autofs (rw,fd=4,pgrp=389,minproto=2,maxproto=4)
Interesting. I have the /mnt/auto directory, but never get automount there (which has Process ID 389 in your listing).

I deleted ... entries for "Added by Knoppix"
Oops, oops, oops. My bad; my very very bad. Put them back - you want them.

What I meant was that you could delete the lines that were already comments and said, literally,

# Added by KNOPPIX (meaning that the next line was added by Knoppix).

The entries themselves are what you need, the comment as to who put the entries in the table are annoying to me and so I deleted them (the comments). You can leave the comments in, add to them, whatever you like.

But to have your USB, swap, and FAT32 systems automatically mounted at boot time, their entries have to be un-commented. With them commented, you can still mount them manually - that isn't blocked. But that's a pain, so put them back in. I'm sorry! :oops: :oops: :oops:

Okay, like it or not, you're learning Linux! :D Commenting out those entries, rather than erasing them, is very good. It doesn't take any more work and lets you recover from bad advice.

Now, the line in /etc/fstab that says:

/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

includes the option noauto, meaning that it doesn't get mounted automatically. That's why it didn't show up in the list you got after running mount. So, to test whether commenting out that DVD line has fixed your problem, try typing either

# mount /dev/cdrom or

# mount /cdrom

For an entry in /etc/fstab, you only need to specify one, and mount will go look up the other. For anything that's not in /etc/fstab (inicluding lines someone shouldn't have told you to comment out), you need to type something like

# mount /dev/cdrom /cdrom

If mount can autodetect the device type, that's all you need. If it can't, it'll complain and you'll need a more complete command like

# mount -t iso9660 /dev/cdrom /cdrom

If you want to specify any options that aren't already included in the /etc/fstab (stuff along the lines of the "defaults,ro,user,noexec,noauto" that you do see) those need to be specified in the mount command too.

Anything that is already mounted can be unmounted with umount.

By the way, the option ro means read-only. Mounting something that you can write to uses rw or, often, mount will automatically decide that it can be mounted read-write (like Linux hard-drive partitions), and then specifying rw isn't necessary. CD drives tend to get mounted read-only by default. (But you can change that in /etc/fstab.)

Also by the way, this entry:

/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0

is yet another reference to your CD drive. Don't act on the information yet; but do recognize how darned similar it looks to the DVD and CD entries.

Enough for now? :D

-- Ed

Victor Warner
02-20-2005, 09:29 AM

I tried 'ln -s /dev/scd0 /dev/cdrom' (after deleting /dev/cdrom) and the CD starting working.

However, since I am new to Linux and trying it out stage, I decided to wipe the hard disk amd install version 3.7 and the CDROM now works without any commands and also can play audio CDs as well.

Thank you for your help.

Ed, thank you for your further response, which helps me understand a bit more about how Linux deals with such issues.

Victor Warner

02-20-2005, 09:48 AM
Holy mackerel - are you saying, in essence, that all you had to do was start over and then everything worked? :shock:

However you did it - great job! :D :D :D

Now enjoy!

-- Ed

A. Jorge Garcia
02-20-2005, 02:40 PM
I did the same as Victor and got the same result....

What now???


02-21-2005, 04:32 AM

Check over in your thread:


-- Ed