View Full Version : Knoppix 3.7 AFU Full Debian install KDE wont work

02-13-2005, 11:49 PM
Ive been trying do a full Debian install of this new AMateur Funk Distro 3.7 but run into a problem constantly. I suspect something is missing in the distro. It all appears to work fine but on boot up it gets to the user login screen and then comes up with a error box. Its releated to KDE . I can run FluxBox or IceWm desktop etc fine but KDE refuses to load. The error box says. "There was an error setting up inter process communications for KDE. The message returned from the system was could not read network connection list /home/knoppix/.DCOPserver_Knoppix3.7 Debian__0 . Please check that the Dcop server is running."
SO on realising this was a KDE desktop initialization issue I started to look at other desktops for now but unfortunately they dont have much to offer on the desktop and for a Windows junkie like me its all a bit confusing. I have done a check of the CD (2 of them) using the checkcd feature and also done the other installs Beginers and Knoppix types and these are fine. I would prefer to have the Debian install though by a long shot. I did a Debian install using the 3.3 knoppix CD and that was also fine but somethings missing here on this Amateur funk 3.7 distro I fear.
Any help greatly appreciated Thanks Tony Hunt.

02-14-2005, 02:09 PM
Not sure if this helps, but how did you install? If you do it from Ctrl-Alt-Fn KDE might not work, so try installing from a konsole while logged into KDE.

02-15-2005, 01:24 PM
Hi Markus, Yes I was wondering the same thing .. Ive been trying for days.. As Ive said Ive done installs using the Beginers install and also the copy from CD but the full debian install Ive tried probably 10-15 times and get various results using different approaches.. Using Ctl Alt F1 does not seem very good.. Ive used KNOPPIX-INSTALLER and allways have to specify the IGNORE_CHECK=1 option to get into the install menu even though there seem to be a swapp file of 800Meg available and a Linux partition of 3.7Megs as well. Ive tried using a console from within KDE and used KNX2HD which appears to be the same script but when it runs the partition checks up it uses QTPARTED or what ever its called instead of CFDISK.. This seems better . I have rebooted after making partition changes and run it again to check before proceeding with the install. The best I get is a system that runs up fine apart from having no KDE ability. This DCOP server not running is what I end up with and thats the closest I get to a complete install. I wonder if my CD image is in error ? Ive run the checkcd option allready on 2 CDs .

02-15-2005, 03:33 PM
Did you check the md5sum of the iso? Not sure how reliable testcd cheatcode is.
Also you could try renaming .kde under the user directory and have it recreated.

EDIT: This might be of some use.
markus@fujibox:~$ ls -la .DCOP*
lrwxrwxrwx 1 markus markus 39 Feb 15 19:05 .DCOPserver_mrk-fujibox_:0 -> /home/markus/.DCOPserver_fujibox__0
-rw-r--r-- 1 markus markus 58 Feb 15 19:05 .DCOPserver_mrk-fujibox__0

I noticed that in your first post the hostname is "Knoppix3.7 Debian". If that's a space between 7 and D you might want to change /etc/hostname as linux doesn't quite like spaces in filenames or otherwise.
What if you create another user which you should do anyway. Does KDE work for the new user after changing hostname?

02-20-2005, 08:49 AM
:D Thanks Markus, The space in the host name was the problem. Ive still got a lot to learn about Linux .. All working ok now.

02-20-2005, 09:55 AM
Heh - and I was going to suggest installing pure Debian from a Debian net-install CD. :D

Good job, guys!

-- Ed