View Full Version : watch out for the "tohd" cheat code

02-16-2005, 07:59 PM
yeah, instead of using sudo knoppix-installer, (hand't seen that) I tried the tohd which I found in the cheat codes file. Don't know which version, don't have it with me. But it wrecked the hard drive, I mean I had to go out and buy a new one, spent ages in parted and fsck, dosfsk and all that. But it was like I'd taken that hard drive out and kicked it round the room. Not angry or anything, my risk and all, got a new hard drive and did knoppix install, really like it, of course it's debian, but I like the whole idea. Thank ya. God bless :D

02-17-2005, 03:21 PM
Hmm...that's weird!
You couldn't even stick it in another computer (as slave) and format/fdisk it?

02-17-2005, 03:28 PM
Let me get this straight: you typed "tohd=/dev/hdxx" at the KNOPPIX splash screen, and next thing you knew your HD was trashed?

As far as I know, when you type tohd, all that happens is that about 700MB of stuff gets copied from the CD to a directory called knoppix in the top level of the partition you indicate. And if there isn't enough room or it doesn't accept the partition's type of format, it doesn't copy anything. In that sense, I've used it a lot precisely because it has always been extremely "low impact" for me -- from the windows perspective, no more than "just another folder" in my root directory.

So I am curious what other details you noticed. Like:
Did the drive have an unusual configuration? Was it NTFS? Is it possible the drive was "hanging by a thread" to start with?

02-17-2005, 04:41 PM
well it certainly wasn't hanging by a thread, of stuff that had happened on it since I bought it, all that I remember going wrong before was one or two circular references on my fat32 partitions, which dosfsck fixed. I did the tohd thing, and then when i tried to run knoppix from the hd, it would give something like seek error(etc etc) :41009, over and again then reset(0) or something like that and then repeat itself whenever it was trying to read from the hd. I don't have any info with me (on a friends comp). Then I went and booted my red hat 9, and it did the same thing when trying to load kde, tried booting windows and it would just freeze as soon as grub chainloaded, and errors were just popping up everywhere I tried to access the hd, on every partition. As to trying to fdisk it etc, I tried that, running the knoppix cd and using fdisk, which wouldn't even read it, qtparted which crashed consistently, and parted which worked best but didn't fix it at all. I even tried a 5 hour dos format from a recovery disk, where it said "trying to fix allocation unit 5009" up to about allocation unit 10000000 or such, and it didn't do a single good thing. Still if it works ok for you, perhaps it was a fault in the copying of the cd, I didn't do any md5 checks or anything. Oh and also, no NTFS, I much prefere 98 to all these new fangled XP's, 2000s, and what not. Ah well, all this said, and the end of the day, the most important thing is that Jesus loves you, died for you, rose again and wants a relationship with you and all you need to do is invite him into your life. God bless :D

02-17-2005, 09:05 PM
have you tried a lowlevel format? or perhaps first a "zeroing" of the disk (if that is not enough try low level formating).

dd if=/dev/zero of=/dev/hd bs=512
these actions will WIPE the ENTIRE drive fairly well.
any atempt at data recovery after the fact will not be easy, some might say near impossible.
you might recover fragments of files after this, perhaps even whole files, but it will cost you time/money/hairloss/ulser... so be carefull.

02-18-2005, 12:20 AM
have you tried a lowlevel format? or perhaps first a "zeroing" of the disk (if that is not enough try low level formating).

dd if=/dev/zero of=/dev/hd bs=512

What does the bs=512 do? I have formatted with dd if=/dev/zero of=/dev/hda before, but I am not sure what the bs does...

02-18-2005, 08:09 PM
it is just sets the blocksize to 512, yes 512b is default, BUT it is only on the READ side, on the write it might truncate the size to fit, so i forced it.
man dd for more.