View Full Version : After HD install root login problems!

02-17-2005, 06:37 PM
I installed Knoppix with Grub.
The knoppix-installer choice: Systemtyp

I selected Debian

The Installation was successfull.
I restart the Computer, Grub booting Linux. Perfekt

Welcome To Linux at XXXX

I see at the login only one user ther is no root user
nevertheless, i try to login as root with pass.

Anmeldung des Benutzers root ist nicht zulässig
Login as root is not allowed.

1.Why is it not allowed to login as root?
2.How can i change it?
3.Is the Problem maybee KDE?
Any feedback is very much appreciated.


02-17-2005, 08:06 PM
Root login is disabled in kdm for security reasons. You should always use su,sux or kdesu from a user login to do admin tasks.
If you really need to change it, change /etc/kde3/kdm/kdmrc AllowRootLogin=false to true.

02-17-2005, 08:41 PM
i would advise to not log in as root because everything you do will be done as root. that includes browsing the web, irc , etc etc


02-18-2005, 12:26 AM
Agreed. unless you're installing, changing permissions, auditing security logs, etc... NEVER use root.
In fact, type su, login as root, use the command visudo
and add your username under the root all=(all) all
to look like this user all=(all) all

This setup will allow you to use the command "sudo" before a root command as your normal user.

Linux gurus, if i have missed something, tell me please.

02-18-2005, 03:36 PM
@Markus, Wow, it works.
Thanks, very much, one question, one answer.
In the most time i get comments. about how i have to handle this and how i have to handle that.
In the most time, they have no solution for the problem, but a lot of tipps.
they do not notice, that it no answer is.
But this is Perfekt, really, really perfekt.

Look in other Forums you will find ther threads with 40 - 50 Postings about this topic, everyone knows everything but no one has a solution.

i start as user kwrite and try to open /etc/kde3/kdm/kdmrc
I couldn´t edit this file.
:shock: :cry: :x :evil: :twisted:
i start the root terminal, type kwrite. I open /etc/kde3/kdm/kdmrc, second try to save, wow it works.
now I understand slowly why it isn´t good to login as root in KDE.

Thanks, for the Help, and go forward MARKUS

02-26-2005, 11:37 PM
I'm very new to Linux/Unix. I loved Knoppix 3.6 and just upgraded to 3.7. However, having read your posts, I have an additional question. I attempted to edit my sources.list file and the kdmrc file to allow the proper paths in apt-get and also to allow me to log in as a root user (as I am still very bad with Linux command line...I'm still very new to this environment). I tried to do what Siri did...went into terminal, accessed root using "su", entered password, typed "kwrite"....I received some Xlib error...not sure what I did wrong.

I just need to edit sources.list and kdmrc and save them. Can anyone help? Alternatively, how can I edit files in KWrite using my normal user name then access the root to save them???



tom p
02-27-2005, 10:09 AM
I tried to do what Siri did...went into terminal, accessed root using "su", entered password, typed "kwrite"....I received some Xlib error...not sure what I did wrong.
That X error was presumably "Xlib: connection to ":0.0" refused by server"; solution: either open the root shell from the Knoppix menu, or before you do the "su" command, enter "xhost +localhost" to grant permission for everyone one your computer to open X programs on your display (that's presumably only you :-)


02-27-2005, 04:59 PM
There are a number of ways to work as root without actually logging in as root. For terminal applications, use sudo and su. If you have done a Debian type install you will have to edit /etc/sudoers before you can use sudo. Here's my sudoers file:

# sudoers file.

root ALL=(ALL) ALL

# KNOPPIX WARNING: This allows the unprivileged knoppix user to start commands as root
# KNOPPIX WARNING: This is totally insecure and (almost) makes knoppix a second root account.
# KNOPPIX WARNING: Never allow external access to the knoppix user!!!
crashedagain ALL=NOPASSWD: ALL
The comment about editing only with visudo at the beginning of the file is simply not true, BTW , you can use any text editor.

There are good text editors in linux which can be run directly as root (eg:sudo mc <filename> or sudo joe <filename>) but for gui applications you will get the error:

Xlib: connection to ":0.0" refused by server

The cure for this is to type 'xhost local:' as user before you attempt to do open kwrite or other X applications as root.

Another way is to use kdesu to open the application, eg'kdesu kate /etc/fstab' will open your file /etc/fstab using the text editor Kate as root (better editor than kwite, has built in terminal & other features). Kdesu needs a password so you may have to set one first with 'sudo passwd'.

For convenience, I have desktop icons for Konqueror-as-root & Kate-as-root. These were created by drag'n'drop copying the Kate & Konqueror menu items from the start menu to the desktop then editing the properties application to run to 'kdesu application' instead of just 'application'. These shortcut links will give an odd error 'kdesu unable to start application' after it has already started the application, the cure for this is to open the desktop link in a text editor and comment out the line 'X-DCOP-ServiceType=multi' by putting a # in front of it (eg: #X-DCOP-ServiceType=multi).

You will not be able to edit any of the setups for the root applications when running under kdesu so you may have to enable logging in as root by changing /etc/kde3/kdm/kdmrc AllowRootLogin=false to true if you want to change any settings, file associations, colors etc for your root applications. I set my color scheme for root to something distinctly different from the user setup so that if I do have konqueror running as root I will recognize it immediately.