View Full Version : Behaving like Windows ...

02-17-2005, 06:53 PM
Hey Folks,

I don't want to insult anybody, but I had a very weird experience just now. I'm running Knoppix (3.7?) and was listening to some cds on XMMS. CD x finished playing, so I inserted X+1, added the tracks to the playlist and clicked on play - business as usual thus far. Well, some seconds later I discovered that the mouse pointer was frozen. And so was everything else. I tried Ctl-Tab to change desktops. Nothing. I tried Ctl-Alt-F1 to go to console login. Nothing. In the meantime the 1st track on the cd (Mark Lanegan - Whiskey for the Holy Ghost, if you wanted to know) was playing. But when it ended, that was it. Track 2 did not play. Btw, while track 1 was playing, the XMMS display was not being updated (you know, time left, track name, etc.).

Anyhoo, I realised that this problem was beyond my limited capabilitiesd and, like a good ol' windows (what's the ASCII code for that trademark thingy?) user, I hit the reset button and sat back, waiting for the problem to "disappear". Well I usually boot into the graphical login, but this time it took me to the console login. No sweat, GRUB offers me three options (Linux, Linux 2.4 and Linux 2.6), so I picked another option and booted. But, lo, I ended at the text login once again. No sweat, got one option left, reboot time (good ol' windows, eh)!

Except that this option didn't boot. Started booting and, about two seconds later, started hanging. Ain't nothing happening here, move along folks.

So I rebooted again and waddayaknow? Booted right into the graphical login... Go figure...

So, if anybody has had a similar experience or if anybody can state categorically that this is "an undocumented feature", please post something to that effect, because it's got me worried - if I wanted this kind of behaviour, I would have stuck with windows.


02-17-2005, 07:13 PM
Honestly, this sounds an awful lot like a hardware problem. At first I thought it sounded like a hard drive problem, except you said that it seemed to correct itself after a second boot.

This is not normal behavior. When something like this happens on a Linux system, it happens for a reason. What I would do is install the smartmontools package, which will report any errors your hard drive is reporting just to be sure.

But what it sounds like to me, is that you might have a case of bad RAM. I'd also try booting with a Knoppix CD with the "memtest" cheat code and see what the story is with your RAM.

02-17-2005, 09:23 PM
just an aditi0onal thing. let the memtest run for a LOOOONG while. sometimes ram might not fail first or even second pass.

02-18-2005, 12:17 AM
Your experience was most likely due to the filesystem being incorrectly shut down. A few reboots will usually cause the filesystem to be checked and corrected at some point. Glad to hear you are back up and running.

02-18-2005, 09:25 PM
Thanx for the good advice guys, it's much appreciated.

I'll install smartmontools and run the memtest (and come running for help **if** something goes wrong :).


02-19-2005, 11:55 AM
Not long ago I was surprised to hear a tech (my son, actually) tell me about a system he worked on that turned out to have a bad stick of memory. I haven't had any such problems in a long, long time and thought that they were a thing of the past.

Not so, apparently, and the symptoms can be very confusing. He had looked at the hard drive and a few other likely suspects before finally tracking it down.

When programs get copied into bad memory, they don't work right. When stuff is written from bad memory to hard drive, it's corrupted so that even if it gets copied into good memory the next time, it's still bad.

Yuck, yuck, yuck. And do run different patterns, the more variety, complexity, and length of time, the more likely you'll find the rotten apples.

-- Ed

Durand Hicks
02-24-2005, 06:31 AM
Here's a trick I did from windows, but you can also try it in knoppix or any linux distro that supports a ramdisk:
Create a ramdisk to use almost all of your memory and put a filesystem on it.
Then you can run fschk on the ramdisk and when it hits the bad block on the memory it will short that chip out, causing your system to crash totally. Don't worry, just reboot and try again, and repeat as often till it doesn't short out anymore.
Basically, what happens (in theory) is that the fschk will attempt to patch the bad block and when it can't, it will be marked as bad so you won't be using that bad block anymore. As a result you might see less memory available but it will be useable and reliable.
I did this a long time ago out of the blue when I was having trouble getting correct memory reads and then I had a ramdisk that used all of my memory and ran a thorough scandisk on it with the fix enabled.
It shorted out the bad blocks and crashed windows. Then I rebooted and noticed that I had slightly less memory but what was left was reliable since scandisk didn't short it out anymore afterwards.
Oh and by the way, this doesn't take long at all, almost instantaneous IIRC.


03-06-2005, 11:11 PM
I have a problem that's just like his, here's what happened: While I was using my computer to download something, it froze, and I tried to go to the console using ctrl+alt+F1 but it didn't work at all, by the way this happens to me very often, so what I did was press the restart button, and as always, I can't go back to graphical login, all I got is console login, and doesn't matter how many times I try, it won't go back to graphical login, I believe that this is probably caused by not shutting down the OS properly. Does anyone know a way to go back to graphical login from the console, or a way to make it boot strait into graphical login? Oh, another thing, Today, before the computer crashed, my computer was on for approxmately 3 hours,it wasn't used at all and when I come back, everything is working very slow at first I even thought it was frozen, but when I restart it, it was running fine again. Can anyone tell me what is wrong with my computer? If I can't find out what is wrong I really have no choice but to use windows, cause the windows on the same computer is working just fine.

ps. I am a total noob to Linux, so please use the simplest explanation.


03-07-2005, 04:22 PM
Hi, i had that problem of the graphical login not loading up and i managed to solve it. Don't know wether it'll have the same results as you though.
At the console login, i loged in to root. Typed "init 5" a few instances. Then rebooted. After that, my computer would be back to normal. Hope that works somehow.