View Full Version : problems finding some installed packages

02-20-2005, 08:10 AM
i'm a very new linux user, and knoppix has been the best i've tried by far :D i am having a small problem though.
i've installed a few packages with apt-get, updated my menu, some apps show up in the menu some don't.
as far as i can tell, they all have installed properly, yet i can't get some of them to show up in my menu.
how can i get them there? where do they install to? can i put them in the menu myself?

what i installed and can't find is: bittornado, kweather, firewall-easy, and openwebmail

can i run a command to open them?

02-20-2005, 08:29 AM
Hi, welcome!

Which menu are you looking at, the one with the K-and-gear icon?

Have you tried the KPackage package manager? It'll tell you for sure what's installed. Click on the K/gear icon, then look under System.

-- Ed

02-20-2005, 04:56 PM
yeah, i'm looking at the right menu. i spent at least an hour and a half scouring it looking for what i installed. i looked through the installed tab in kpackage, and i found all of what i'm looking for. it has all installed ok. i've ran the menu updater under settings a few times and rebooted twice to see if they would show up. :(

02-20-2005, 06:55 PM
Right click on the desktop, select run command, and run bittornado, or whatever.

You can also try in konsole the command: ls /usr/bin | grep kweather, this should give you a list of any command that contains 'kweather' in it.

Or type something like bitt, and hit tab twice (this should give you a list of all commands that start with bitt).

02-20-2005, 08:07 PM
i tried the command in konsole for each and got a list of commands for each, so i know they are there for sure.

i've almost went through the whole list of commands and haven't got any programs to launch yet.

none gave me any kind of could not run specified command error, so i'm typing them correctly, just no result as far as i can see

thanks for the help! its helping me learn quite a lot while i'm trying to resolve this issue. :D

02-22-2005, 06:50 AM
i managed to find kweather by right-clickig an empty bar spot and found it in the add applet section.

the one i really want to find is bittornado, dont want to have to resort to windows for bittorrent. :cry:

none of the above commands have produced any results that have helped :?

02-22-2005, 07:18 AM
locate to the rescue!
$ sudo updatedb
$ locate <bittornado>
find the executable, and run it by typing
$ cd <directory containing binary>
$ ./filename

02-22-2005, 08:32 AM
Got Bittornado in my menu!! :D :D :D
the locate command helped me find a debian readme file on it, and i needed to install bittornado-gui package
now to try this on the others i can't locate.
thanks a whole lot!! :D :lol: :D

02-22-2005, 06:57 PM
You're welcome! locate is an extremely useful and powerful tool and I always recommend putting updatedb in your crontab so that it will run periodically and not take as long when you need to do an update for a specific search of something you installed recently.

Durand Hicks
02-24-2005, 05:57 AM
Did you by any chance try running update-menus in a console to refresh your menus?