View Full Version : I am a complete novice - knoppix won't get past fsck

02-21-2005, 04:07 PM
I am completly new to linux. I had knoppix 3.7 installed on my laptop for me for use on a uni project. I have been using it exactly as installed since October and been fine. I haven't messed around with any settings, I've just used it to do my work and been happy.

For absolutely no reason that I can see, today it has decided not to boot up properly.

I have searched forums and found other people who have had the same problems, but I don't understand the replies they have recieved.

It goes as normal until it strarts checking the root file system.

I then get:

fsck 1.35
WARNING: Your /etc/fstab does not contain the fsck passno field.

fsck.ext2: is a directory while trying to open /
the superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

fsck failed. Please repair manually and reboot. Please note that the root file system is currently mounted read-only. To remount it read-write: etc

How do I repair it? Or what can I do to at least get things up and running so that I can retrieve my project work somehow. I can access the directry the work is in but it won't mount the floppy drive properly so there is no where I can transfer it to.

Please help, and please remember I have no idea what I'm doing, so you'll need to be precise.

02-21-2005, 05:08 PM
Try to run fsck manually: when you get the error message do:

fsck /dev/hda (or whatever -- you want the drive that Knoppix is on).

Let us know what happens.

Or what can I do to at least get things up and running so that I can retrieve my project work somehow. I can access the directry the work is in but it won't mount the floppy drive properly so there is no where I can transfer it to.

Probably the easiest way to do this is to boot up from a Knoppix CD. You can then mount the partition on which the stuff you want is and copy it to a (mounted) floppy. In fact, it's probably a good idea to do this before trying anything else.

Again, don't panic --- most data loss is caused by people panicking and trying something too adventurous --- and do get back.

02-21-2005, 07:11 PM
I have found USB flash keys much easier to mount than floppies. Do you have one of those?

02-21-2005, 10:13 PM
running fsck on hda5, which as far as I can tell is the main linux partition, it doesn't say anything (apart from a warning about /etc/fstab does not contain the fsck passno field...). I'm assuming that it just going back to the prompt without givin me an error message should be it was successful?

The only one I get any error message from is what I presume to be the windows partition (mentions ntfs).

I managed to copy my files onto a floppy using mcopy (i still haven't managed to mount the floppy succesfully) but windows won't recognise that there are any files on the floppy, and I don't have easy access to another linux machine.

Attempting to download the .iso image of knoppix to run from a cd, however even on my broadband connection it is taking ages.

02-21-2005, 11:03 PM
How did you copy the files to the floppy without mounting it? You should probably format the floppy using fat16 if you want it to be readable in a windows machine.

02-21-2005, 11:20 PM
on the say so of someone in a linux help chat room, I used

mcopy <file> a: /

the floppy drive made its usual 'i'm being used' noises and linux seemed to think it had copied my files.

when I tried to write the same file again it asked me if I wanted to overwrite the existing file, so I believed it.

But windows thinks the disc is empty.

How do I format the floppy with fat16? Will I be able to do this even if I can't persuade it to mount the floppy?

02-22-2005, 03:34 AM
Just go into windows, put the floppy in, right-click and format...
choose fat16, and then let it do its thing.
Next, get back into knoppix and use these commands:
$ sudo mkdir /mnt/floppy
$ sudo mount -t vfat /dev/floppy /mnt/floppy
Then do
$ cp <file> /mnt/floppy
$ cd /mnt/floppy
$ ls
check to see if the file is in there.

02-22-2005, 09:18 AM
sudo: unable to lookup Knoppix via gethostbyname()
mount: special device /dev/floppy does not exist

02-22-2005, 02:29 PM
Problem fixed.

I gave up in the end for fear of doing more damage and handed it over to someone who knows what they are doing.

It turns out that for some reason, the /etc/fstab file was completely empty (so where it was complaining about a particular field being missing, it was because there was actually nothing there at all). Apart from making files difficult to access properly, this interupted the boot process and so a whole load of other things weren't working correctly either.

After adding the main linux partition to fstab correctly knoppix managed to fix the rest itself at the next reboot.

Lesson learnt: Make a backup of /etc/ to replace settings should this happen again.

02-22-2005, 06:53 PM
Glad to hear you got the problem resolved. :)