View Full Version : Linux boots but Windows XP does not

02-24-2005, 07:37 PM
I installed KNOPPIX 3.7 to the hard disk using basic install, made it so that it writes boot data to the MBR. The problem occurs with LILO. It boots linux fine, but when I try to boot to the WinXP/2K(hda5) it just displays Loading WinXP/2K(hda5) and the hd light does nothing - and it just hangs.

I'm using a Compaq Presario 2570 US Laptop with this.

Any ideas? I tried installing to the boot sector of the drive and it just went to the Win XP install... and when I try that it says C:\Windows\System32\hal.dll is messed up.

I have a ghost image I did yesterday before I started all of this but I want to use linux with windows. And I don't want to do a fresh install of Windows as it takes at least a day to set it up and disable unnecessary services that leave it open to hackers.

02-25-2005, 12:31 AM
N/M - i found out what was going wrong. When I original installed Windows XP on my laptop, I also installed MS-DOS 6.22. I pointed the Lilo boot loader to the "Windows(hda1)" partition instead and it worked. To think that I wasted 4 hours last night installing knoppix, restoring ghost images, and re-installing knoppix... ARGH. But it's worth it :-)