PDA

View Full Version : WLan mit Dell TrueMobile 1180



manne-p
02-26-2005, 01:25 PM
Hi,
ich benutze Knoppix 3.7 mit einem Dell TrueMobile 1180 WLan-Adapter.
Leider bekomme ich ihn nicht zum Laufen.

Wenn ich den Befehl lsusb ausführe wird folgendes ausgeben:
Bus 001 Device 002: ID 413c:8100 Dell Computer Corp. TrueMobile 1180 802.11b Adapter
- also richtig erkannt, oder?

Wenn ich ifconfig ausführe wird folgendes ausgegeben:
wlan0 Protokoll:Ethernet Hardware Adresse 00:00:00:00:00:00
inet Adresse:192.168.178.5 Bcast:192.168.178.255 Maske:255.255.255.0

Kann es sein, dass wlan0 gar nicht mit der Hardware in Verbindug steht?
Beim Ausführen von KNOPPIX/Netzwerk/Internet/Funklan konfigurieren
bekomme ich diesen Fehler: Keine Wireless-Netzwerkkarte gefunden

Habt ihr ne Idee?

Danke,
Manne

tom p
02-26-2005, 03:21 PM
Wenn ich den Befehl lsusb ausführe wird folgendes ausgeben:
Bus 001 Device 002: ID 413c:8100 Dell Computer Corp. TrueMobile 1180 802.11b Adapter
- also richtig erkannt, oder?
Huh? Ein wenig googlen sagt mir, dass das alles, aber doch kein USB-Gerät ist, oder!? Was
sagt denn "lspci -v" und "lspci -vn" dazu?


Wenn ich ifconfig ausführe wird folgendes ausgegeben:
wlan0 Protokoll:Ethernet Hardware Adresse 00:00:00:00:00:00
inet Adresse:192.168.178.5 Bcast:192.168.178.255 Maske:255.255.255.0

Kann es sein, dass wlan0 gar nicht mit der Hardware in Verbindug steht?
Beim Ausführen von KNOPPIX/Netzwerk/Internet/Funklan konfigurieren
bekomme ich diesen Fehler: Keine Wireless-Netzwerkkarte gefunden

Eine Hardware-Adresse nur mit Nullen deutet stark darauf hin, dass das Gerät nicht erkannt
wurde. Was sagt denn "iwconfig"? Möglicherweise musst Du das Gerät eher mit "Ndiswrapper"
als mit "Funklan" konfigurieren...

Thomas

manne-p
02-26-2005, 03:47 PM
Bin mir sicher, dass es ein USB-Gerät is, liegt ja vor mir :)
lspci -v sagt nix dazu, is ja ein USB-Gerät...

iwconfig:
wlan0 no wireless extensions.

Wenn ich z.B. die SSID hinzufügen möchte kommt das:
iwconfig wlan0 essid fritzbox
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device wlan0 ; Operation not permitted.

Ndiswrapper hab ich schon probiert, der bringt diese Fehlermeldung:
The ndiswrapper module has been loaded but there is no new device.
Perhaps NdisWrapper is not working with your driver file.

Welchen Treiber sollte man am besten verwenden?
WinXP, 2000, 98 ??

Was mich wundert, ist dass unter lsusb das Gerät richtig erkannt wurde.
Warum wurde es aber nicht mit wlan0 "verknüpft"?

Thx,
Manne

tom p
02-26-2005, 04:36 PM
Bin mir sicher, dass es ein USB-Gerät is, liegt ja vor mir :)
lspci -v sagt nix dazu, is ja ein USB-Gerät...
ok :-)

Welchen Treiber sollte man am besten verwenden?
WinXP, 2000, 98 ??
Auf alle Fälle einen WinXP-Treiber, wenn vorhanden!

Was mich wundert, ist dass unter lsusb das Gerät richtig erkannt wurde.
Warum wurde es aber nicht mit wlan0 "verknüpft"?
Dazu bedarf es eines Treibers im Kernel, der mit dem Gerät mehr anfangen kann,
als nur die Geräte-ID auszulesen (die ist im Gerät selber "verdrahtet"). Und das
wird in diesem Fall wohl der Ndiswrapper sein. Ich empfehle Dir, Dich mal unter
http://ndiswrapper.sf.net umzusehen - dort stehen
in der Hardwaredatenbank sehr gute Hinweise (zum Teil auch Links zu alternativen
Windows-Treibern), wie man ein Gerät ans Laufen bringt.

Thomas

manne-p
02-27-2005, 11:22 AM
Hab die Lösung gefunden:

Einfach im root-Shell das eintippen:
wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_autojoin ssid=fritzbox authtype=opensystem

Dann kann auch "Funklan konfigurieren" ausgeführt werden.

Gruß,
Manne