PDA

View Full Version : Probleme beim Laden der Knoppix-Konfiguration (per Diskette)



Maverick81
02-28-2005, 03:39 PM
Hallo,
ich benutze Knoppix 3.6 (CD-Version) und habe mir eine Diskette mit sämtlichen Konfigurationen erstellt, damit ich nicht jedes mal mein Desktop neu einrichten muß und auch die anderen Einstellungen automatisch vorgenommen werden.
Das ganze habe ich über das Menü "Knoppix->Konfiguration->Knoppix-Konfiguration speichern" gemacht.
Die Diskette wird (denke ich) auch einwandfrei erstellt. Er erzeugt die beiden Dateien: configs.tbz und knoppix.sh

Das Problem ist allerdings, dass ich diese gespeicherte Konfiguration irgendwie nicht wieder laden kann.
Wenn ich den Computer neu starte gebe ich (wie nach dem speichern angegeben) folgendes nach "boot:" ein:
knoppix myconfig=/mnt/floppy
allerdings gibt er dann aus, dass er das Verzeichnis "/dev/floppy" nicht findet (was ich auch gar nicht eingegeben habe)
habs dann auch mal mit anderen Verzeichnisangaben versucht
myconfig=file:/mnt/floppy
myconfig=../mnt/floppy (um eine Ebene höher als dev zu gelangen)
...

Leider klappt aber keine Variante und ich muß jedes mal beim Neustart mein Knoppix völlig neu konfigurieren. :-(
Kann mir da vielleicht jemand helfen, wie ich meine auf Diskette gespeicherte Konfiguration laden kann?

Gruß, Maverick

mecolodic
03-21-2005, 10:08 PM
Hallo,
ich benutze Knoppix 3.7 (CD), die Diskettenkonfiguration sollte aber ähnlich sein.
Als Du den letzten Dialog bestätigt hast stand da bei mir :
knoppix myconfig=/mnt/auto/floppy oder
knoppix myconfig=scan
eingeben, um die gespeicherte konfiguration zu laden. probiere das doch mal aus.

( Sonst kannst Du auch die Kofiguration erneut speichern und auf das letzte Fenster achten. )

Fehlermeldung '/dev' hat glaube ich folgenden Hintergrund :
Beim Systemstart erhalten erkannte Geraete einen Link in /dev nachdem das Gerät gemountet (eingebunden) wurde z.B. mit "mount /dev/fd0 /mnt/floppy" steht sein Inhalt in dem Ordner /mnt/floppy zu Verfügung.
Wenn du /mnt/floppy angibtst wird versucht die zugehörige Device in /dev zu finden, um sie zu mounten und dann auf seinen Inhalt zuzugreifen.
Prima ist schon mal, das Du die beiden Dateien auf der Floppy gefunden hast - das scheint Die Konfig zu sein.
( War die Diskette leer + evt. frisch 'ms-dos' formatiert ?)

Beides habe ich auch schon probiert, die Konfig-Dateien liegen auch beide da.
Trotzdem bekomme ich die Meldung 'unable to mount' der Retry aendert nicht wirklich etwas,
auch die Frage nach einem passwort bringt mich nicht weiter.
Warum es bei mir scheitert verstehe ich leider noch nicht, da es eine frisch unter dos formatierte leere diskette ist und ich folgende bootparameter probiert habe.

knoppix myconfig=/mnt/auto/floppy
knoppix myconfig=/mnt/floppy
knoppix myconfig=/mnt/fd0
knoppix myconfig=scan
knoppix myconfig=/dev/fd0

Eventuell liegt's an meinem Board (elitegroup vz k7) das einige macken hat, aber von floppy prima bootet.

Vielleicht hat jemand eine weitere Idee ?.

Gruß, Mecolodic