View Full Version : problems installing to Hdd

02-28-2005, 07:42 PM
When I try to install knoppix I always get the message “Opened disk read only – you have no permission to write” I am new to Linux I have tried mandrake but preferred knoppix. Thanks for any help.

02-28-2005, 11:54 PM
Are you doing "sudo knoppix-installer" to start the install?
If you are then maybe you don't have a writable partiton created
for the installer to use. You could use the mandrake cd to
partion your drive if you need to. Good Luck!

03-05-2005, 10:14 PM
i was using "sudo knx2hd" i tried using QTParted and suscsesfully compleated it and now i get the error when i try to install

"Error: Formatting of failed. som messages from
mkfs.ext3: Usage: mkfs.ext3 [-c:-t:-] fliename] [-b
blocksize] [-f fragment-size]
[-i bites-per-inode] [-j] [-J journal options] [-N
[-m reserved-blocks-percentage] [-0 creator-os] [-g
[-L volume Lable] [-M last-mounted-directroy] [-O
[-r fs-revision] [-R raid_opts] [-qvSV] device

Please Help I Am A Linux Newbe and have no idear what is wrong.


03-06-2005, 04:36 PM
I don't know what version of knoppix you're trying to install but for recent versions
"sudo knoppix-installer" is the preferred method.

You might try using "cfdisk /dev/hdX" where X is the drive (represented by a letter) you want to partition.
Qtparted sometimes doesn't work correctly ( in my experiance) If you continue to have problems you
might need to list your hardware and be very specific about what exactly what you
have tried so far.

03-11-2005, 12:00 AM

Im having the exact same problem. knoppix 3.7 english. i boot up, cntl alt F2 , at the prompt sudo knoppix-installer , if i try to partiotion cfdisk says read only, if i just try the install ( drives is already partintioned) it bails out with a mks.3fs error...

any ideas ?

BTW this is a IBM thinkpad A21M , i was running debian 3.0. 10 gig HD. already pationed for 9.5 gig linux 250 swap

03-11-2005, 01:48 AM
Interesting , i do this within X , and it works just fine.

Bug in 3.7 ?

03-11-2005, 09:59 PM
qtparted looks like buggy one... head a necessity to restart it and even restart pc to complete repartitioning - for no obvious reasons :(

03-11-2005, 11:43 PM
Hi, just tried the same when installing knoppix to hd. Got the same error when I pressed ctrl-alt-F1 (or something like that) and ran 'knoppix-installer'. Didn't get any better when I booted without GUI. But right as I'm writing this, Knoppix is installing happily on my (other) machine. How?:

Booted to KDE -> opened Terminal Program from the panel on the bottom -> typed su -> and then typed 'knoppix-installer'.
I then followed exactly the same procedure as before, but now it didn't complain about anything,no error messages, no nothing, it just started formating my partition and then copying files to it.

By the way, I did a : 'mkfs.ext3 /dev/hda1', after trying two times, then another install, but no luck. After this I gave it a last shot through KDE and it worked.

Hope it helps