View Full Version : Mouse works Live but not in HD install.

03-01-2005, 05:46 PM
OK i have searched the forum and found answers but they didnt work

I tried this

sudo mount /dev/hd?? /mnt/hd??
sudo cp /mnt/hd??/etc/X11/XF86Config-4 /mnt/hd??/etc/X11/XF86Config-4.original
sudo cp /etc/X11/XF86Config-4 /mnt/hd??/etc/X11/XF86Config-4

it didnt ask if i want to overwrite so i dont know if it did it or not. I did it as root also same thing
Booted up the HD install nothing changes.

I want to do a copy in paste using Konquerer as it asks if i want to over write but i cant as im not
root. How can i get Konquerer working as root?

03-01-2005, 07:53 PM
By default a copy (the cp command) will not give you any feedback & will not prompt or let you know that it overwrote a file. So if you did not get any feedback from your sudo cp command, then it was successful and it overwrote the original. To get cp to give you feedback and overwrite warning you need to use the -vi: cp -vi /mnt/hdb2/etc/somenewfile.conf /mnt/hdb2/etc/original.conf

As for running konqueror as root: sudo konqueror

If the copy command was successful then this means that your mouse problem is probably not going to be fixed by copying the XF84Config-4 from a running Knoppix CD to the HD installed Knoppix. You may need to investigate the mouse device either: usually ls -l /dev/psaux or /dev/mouse
or investigate the mouse driver in the XF86Conf-4: usually either IMPS/2 or PS/2

I hope this helps.

03-01-2005, 08:35 PM
thanks for the reply,

Its strange as the keyboard does NOT seem to work in KDE or fluxbox but if i push ctrl alt f2 it drops out
and i can do stuff at the command line.

the problem is i need to use knoppix 3.3 as i need to boot the knoppix folder off the hd using a floppy.
I have tried Damn small linux and done a hd install on that which works fine accept it doesnt come with
kismet and the aptget one doesnt work properly for it.

I dont know what else to do now.

03-02-2005, 03:54 AM
As for running konqueror as root: sudo konqueror

'sudo konqeror' will give an xlib error. Use 'kdesu konqeror' instead. kdesu needs a root password so set one first with sudo passwd if you do not already have one.