PDA

View Full Version : can't compile driver module



Placebo
03-11-2005, 08:53 PM
People, I have installed Knopix 3.7 on a hard drive, found a driver for a winmodem: ltmodem-8.31a10.tar.gz. Unpacked it and executed build_module. At the beginning everything is OK. It runs, it checks for system parameters, it starts compiling lt_modem.o. But then:

Using KCFLAGS for gcc version 2.x
gcc -D__KERNEL__ -I/lib/modules/2.4.27/build/include -Wall -Wstrict-prototypes -O3 -fomit-frame-pointer -fno-strict-aliasing -pipe -fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2 -DCPU=586 -DMODULE -DLT_VERSION=8.31a10 -DLINUX -DNO_EEPROM -DLT_SERIAL_MODULE=lt_serial -DFORCEMODVERSIONS -DASMLINKAGE=asmlinkage -c -o ltmodem.a ltmodem.c

Checking for driver products:

Compilation of lt_modem.o failed,
Do assess whether your utilities are up to date as listed within 1ST-READ!
Read Compile_properly.txt from DOCs/.

...

Then I tried with: l ltmodem-2.4.27-1-686_8.31a8_i386.deb - no way. Says that there is a problem with kernel. Building from a source anounces that kernel-headers are somehow different from kernel version. How could this be?? I've just used knoppix-installer to place knoppix on hd and put lilo into mbr. I have two hard disks: one with XP and one with knoppix. Just decided to migrate, but I guess that I will fail without internet :(

Any ideas?!

eon
03-11-2005, 09:19 PM
You could try downloading your kernel sources. I don't know if that will work.

Try this link: http://www.linmodems.org/ They have alot of ideas for winmodems and that's
what you have i.e. a modem made to work with the windows OS. If linmodems.org doesn't
help then you can still buy an external modem on ebay for $10-15 and that, if you choose a
recent or known linux compatible should do the trick. There are also pci controller type internal modems
like u.s robotics about $40 that will work too, and some distros (suse, redhat) have better
drivers for winmodems. Good luck.

Placebo
03-12-2005, 06:39 AM
Well 10x... the greatest pitty is that my modem is in a fact supported by linmodem drivers. According to scanmodem utility:

Class 0780: 11c1:0442 Communication controller: Lucent Microelectronics 56k WinModem (rev 01)
...
The modem has a supported Lucent/Agere DSP (digital signal processing) chipset
with primary PCI_ID: 11c1:0442

:(

Placebo
03-12-2005, 06:46 AM
I viewed 'version.h' file - kernel-headers and kernel are of the same version. However ./ltinst2 says that there is a flavor mismatch or something... but thats the official Knoppix 3.7 version, how could that happen? :?