View Full Version : Can't get my sound to work

03-13-2005, 10:12 AM
Alright, I installed Knoppix on my hard drive, and my sound just doesn't work. I have no sound icon in the system tray, and every time I open sound in xmms or something it gets further in the sound, but I hear nothing.

I've gone into the KDE Control center and turned sound on, and still nothing. Then I tried adding append="alsa" to lilo.conf, then rerunning it, then editing xmms to run with alsa not oss, and still nothing.

I'm using an AC'97 soundcard. And I'm pretty sure my soundcard doesn't error or anything at startup, because I see no error message or anything. And I'm not hearing static, just nothing at all. I've looked through tons of other sound topics and I couldn't find anything.

Help? @_@

03-20-2005, 01:29 PM
First off ...you can find the mixer (the speaker icon that comesup in the taksbar) in the Kmenu under "multimedia" and it's called "kmix". when you bring that up if it looks normal-everything should be good....click on it and turn up all the volumes until you hear something....if there's an X through it you may need to do a bit more....you sould try to add the correct driver to you append line like:
(I have the same soundcard ....ac'97....and thats what I have)

still no luck??....you could then try to recompile the alsa modules
1) "su" to root
2) "apt-get update"
3) "apt-get install module-assistant"
4) "module-assistant"
5) from the menu choose "UPDATE" then "PREPARE" then "SELECT"
6) check "ALSA"
7) from the new menu select "GET" then "BUILD" then "INSTALL"

reboot and cross one set of fingers

just some ideas


03-20-2005, 08:32 PM
What kernel are you running? Which Knoppix version?

03-24-2005, 08:46 AM
Thanks, I'm on Windows right now so I'll post if that all worked once I get on Konppix. I'm running 3.7 with 2.4.27 kernal. I'm going to upgrade to 3.8 soon.