View Full Version : sound card problem

04-08-2003, 09:53 AM
The following errer occurred running the modprode program:
/lib/modules-xfs/kernel/drivers/sound/viacxxx_audio.o: init_module: No such device.
/lib/modules-xfs/kernel/drivers/sound/viacxxx_audio.o: insmod
/lib/modules-xfs/kernel/drivers/sound/viacxxx_auddio.o failed
/lib/modules-xfs/kernel/drivers/sound/viacxxx_audio.o: insmod sound-slot-failed

It was detected by prog but can't work
help thank you


04-08-2003, 02:36 PM
Do you know what sound chip your motherboard is using? From what I remember, via sound support on Linux is really bad, and that's the reason I got myself an SBLive.

04-09-2003, 02:57 PM
The chip is a on board via sound chip on a amd system. Wonder is there any driver for it it was detected ok by sound configure. I think it is short of the driver.

04-09-2003, 03:00 PM
From what I can tell, it is probably the via 82xx (can't remember the exact thing) sound chip. The drivers that come with the kernel are mediocre.

Did you try running the program sndconfig?

04-10-2003, 04:13 PM
Hi, I've got the same problem with my via card. i've tried sndconfig but no luck with that either. does anyone know if the ALSA drivers are any better? I'm using Knoppix 3.1. thanks

04-14-2003, 10:41 AM
IIRC when I last tried it in November 2002, they worked. But with a little tweaking. Given that it was 6 months ago, thing could have changed now. Download it and try :D

04-14-2003, 04:18 PM
problem solved, linked alsa-detect, or something like that in /etc/init.d to /etc/rc.5, works like a charm

04-14-2003, 11:02 PM
Thanks alexcg for posting your solution. It's nice to see that some people don't forget to come back once their problems are solved. Although I have no personal interest in how you did it (because I just have dinosaur hardware) perhaps you could be a little more detailed (if you recall) on exactly what and how you linked alsa-detect? I think this post could be a big help to alot of people w/ via.

04-16-2003, 04:35 AM
Thanks, all, for this wonderful project.
Great kudos to Fabian Franz for alsa.
With the new downolad 3.2-2003-04-15 and alsa in my syslinux.cfg I can play mps's and waves but there is constant cracking static!
I tend to think is a software interupt problem and not a short in my new board. Should I try a different dirver (and if so -- how :?: ) or give in and get a real sound board?
Best Wishes

04-16-2003, 06:49 PM
I found that the sound drivers work perfectly. The poping noise was form using unsupported codex -- i.e. 32kb/s at 22050 kHz sounded very bad. But more standard bit rates worked perfectly for mp3 files.

Here is the beginning of my syslinux.cfg that resides on my boot floppy:
DEFAULT vmlinuz
APPEND lang=us ramdisk_size=100000 init=/etc/init apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga=791 initrd=miniroot.gz nomce quiet BOOT_IMAGE=knoppix home=scan wheelmouse alsa lang=us

My mainboard is a VIA EPIA-M Mini-ITX and the sound is VIA VT1616 6 channel AC'97 Codec.

Again, thanks to all.
Best Wishes