View Full Version : Knoppix installed, but not booting

03-24-2005, 10:53 PM
I installed knoppix on my harddisk and everything seemed to go ok. My trouble is that
when I try to boot my PC, it is not booting Knoppix, but another version of Linux which
I had tried to install.

It looks like my '/' directory has the correct 'vmlinux'.

I expected the install process to setup my boot loader
for me. Do I need to set up lilo or grub?

Jim Anderson

03-26-2005, 05:20 AM
What Knoppix version? Can I assume you get a lilo screen. The reason I ask is that I just installed 3.8 and had a similar problem. In older versions(or maybe it's just me) you simply went to etc/lilo.conf and changed whatever. Well on my 3.8 it doesn't look the same nor does it have any effect on lilo. In fact I commented out everything just to be sure and then did a shell "lilo" and got back a slew of error replies. BUT lilo does come up and boots and everything works. The lilo screen has the countdown in the middle of the screen instead of in the box where it belongs and it lists the other OS's I no longer have. I have found that there is "a whole lot of mapping going on". By trial and error I have managed to get lilo as it should be but I certainly am not an experienced enough linux person to explain any of it. I hope someone else can for both our sakes. :roll:

03-28-2005, 03:27 AM
First make sure it's set for MBR in the knoppix-installer.
Next you should see a console at the end of the install
with Lilo output make sure it's happy at the end (you could also just run lilo again)
Also on my machine (eMachines M5310) Lilo only worked currectly if I boot "knoppix" not knoppix26

What version of knoppix are you running? and what is your output from Lilo?