View Full Version : OGM in Xine

03-24-2005, 11:21 PM
I can't seem to run ogg video in xine after i use apt-get upgrade. It says something about demux. I have no idea what to do. Do i need a new library or something?

03-26-2005, 06:01 PM
I was in the same boat like you after the upgrade, reinstalling libxine1 didn't did the trick because always skip the codec library need in xine for that archives.
The next code work for me

apt-get install libtheora0

03-29-2005, 12:37 AM
That did work, but the library that i could download was pretty old. It didn't work all that well and chopped up quite a bit. I found an updated version at www.theora.org but i don't know how to compile (yes, i'm a newb)
Can you help me out? I have version 1.0 alpha 4

03-29-2005, 03:56 AM
That did work, but the library that i could download was pretty old.
Which are the specs of your machine, i have used always that codec until recently and never encounter that the codec is the problem, always was the hardware. In which program you have these syntoms ? Xine, mplayer...?

If you have in your etc/apt/apt.conf the word TESTING (default in knoppix) then the versiĆ³n alpha3-1 is the top for you, frankly i don't understand why you did and upgrade and keep staying on testing when you could have choose UNSTABLE for the newest realeases (There is great topic on this thanks to Hydralisk: HOWTO: Upgrade to Debian Unstable (http://www.knoppix.net/forum/viewtopic.php?t=2251&start=0))

I obtain the file you mention using apt-get, I don't recommend you compile this package for the dependencies problem you may obtain, I'm reading the README at this moment for compiling but you 'll encounter the problem mentioned.

If you want that codec at all cost :lol:, use the option for unstable on apt-get
apt-get install -t unstable libtheora0 That should give you the version alpha4-1you want