View Full Version : Can't get the right screen resolution

03-27-2005, 06:19 AM
Hi.. I'm fairly new to linux.

I inherited an older laptop (Toshiba Satellite 330CDS) and have been wanting to learn about Linux, so I figured I'd give it a go on this thing. I got Knoppix loaded from the Live CD and did the knoppix-installer to get it on the HDD. That all seemed to work ok.

I then load into linux from the hard drive and KDE comes up in 640x480, even though the screen should be 800x600.
I tried the "linux screen=800x600", then when it's booting, it lists 800x600 in the modes, but KDE still comes up in 640x480.
I searched here and found a suggestion to add the mode "800x600" manually to the XF86Config and XF86Config-4 files (after backing them up, of course), but that didn't work and I set them back from the backups.
Then I searched here again and found "kxconfig", changed it in there, and did the restartx. Now it comes up in 1024x768 and the right and bottom fall of the screen, but at least the characters look right (not blocky). In the Screen resize part of Control Center, 1024x768 is the only option (where 640x480 was the only option before), but kxconfig shows 640x480 if I go back in there.

Any ideas? I've been monkeying with this for two days now and I'm pretty frustrated.. and now instead of being ugly and not having things fit right on the screen since it was too low a resolution, it looks better but is practically unusable since the panel and stuff falls off the screen.

Thanks in advance!

03-27-2005, 06:52 AM
if it's a laptop, it will be a proprietary style vga chip
like Intel 810 on a mobo

in safe mode windows, the option is usually there between 640x480 and something else (800x640 prolly) but you can't make it go accross
I'd say without a driver correctly installed (and bootup is all probe, not specify) you may be stuck until you get into [kdeconfig] (sorry)
editing, it's

03-27-2005, 08:05 AM
Here is what I found out about my video parts in the laptop:

Type Color Bright Dual Scan (800 x 600)
Size 12.1? Diagonal
Dot Pitch .30mm x .30mm
Contrast Ratio 40:1

VIDEO (All Models)
Memory: 4Mbit EDO DRAM, 3.3V 2 MB
Speed 50ns
Hyper Page mode support Yes
Controller Chip C&T 65555
Data Bus Width 64-bit
PCI Bus Architecture w/burst mode Yes: 32-bit, 33 MHz
Graphics Accelerator: Yes with 64-bit BitBLT support
2D graphics support DirectDraw, H/W Cursor
3D graphics support Direct3D
Digital Video Accelerator: Yes
YUV-to-RGB color space conversion Yes
Scaling/Interpolation Yes
DirectMPEG Yes
DirectVideo support Yes:w/Game SDK driver fr/Microsoft
Color Palette 16.7M colors
Internal Support
Colors Support
Full Screen 800 x 600 16.7M colors
Smaller Image 640 x 480 16.7M colors
Virtual Display Mode 1024 x 768 64K colors
Virtual Display Mode 1280 x 1024 256 colors

03-27-2005, 08:39 AM
First, I don't see a "kdeconfig" that you mentioned.

I've now gone into kxconfig and put in the video card as a CT65555 as indicated in the specs I found and set the resolution to 800x600. Then I do the "restartx" thing (which has never really worked for me, unless it's supposed to have me confirm a couple times and then black, then flip to the text stuff, then back to the X crosshatch background with an X cursor and just sit there forever). Then I end up flipping to ctrl+alt+F2 and logging in and shutting down, then turn it back on. But when it comes up, it's back to the wrong resolution again and when I go back into kxconfig, all the settings are back to where I started, ie, not what I just set them to.

What am I doing wrong? :(

03-27-2005, 08:51 AM
not sure what else needs doing.
after quit from kxconfig, i
worked fine for me, though I don't have laptop or know about config on CT5555
so I can't help,
sorry about the kdeconfig
hmmm, and now I see what restartx is supposed to do. hmmmm....
anyhoo, my x screen is missing too. don't know why
would love to have a map of what loads where, where from, and why

03-28-2005, 03:14 AM
I've had a similer problem (I think mine had to do with simply not understanding XF86Config-4)
Anyway my fix was to start up the only distro to load it currectly (SimplyMepis) and
copy the whole "Display" section to my harddrive.

If you give it a try Mepis has a "F3" thing at boot to set video res.

03-29-2005, 02:02 AM
I'm having the same problems, i'm extremely new to Linux and not exactly literate with the terminology yet...can someone email me this in Layman's terms...youmaycllmejesus@gmail.com...i have pretty much the same problem, but my desired resolution is 1024X768