View Full Version : tohd fails

03-29-2005, 10:57 PM
I can boot and run Knoppix 3.4 off the CD w/o problems, but I cannot get it to copy to the HD. Without using the Knoppix CD the computer has WinNT, 256 megs of RAM and everything works fine.

I have tried:
knoppix26 tohd=/dev/hda6
knoppix tohd=/dev/hda6

In both cases copying starts and eventually makes it to 100%, then:
"Copying KNOPPIX CDROM failed. /dev/hda6 possibly has not enough space left." Other than that there are no error messages.

After the process, QPartd shows that /dev/hda6 has 787.47 MB used. I have reformatted, and set to writable, hda6 before beginning each try.

/dev/hda6 is a 1.5 Gig logical partition I have formatted as ext3 (the rest of hda is NTFS). I made the partition in QPartd, formatted it and then did chmod 777 on the whole /dev/hda6 before trying to get tohd to work. I have also tried setting up hda6 as FAT32, but I get the same results.

QPartd shows the disk has:
/dev/hda1 NTFS Active 3.99 GB
/dev/hda2 extended 14.64 GB
/dev/hda5 NTFS 13.15 GB
/dev/hda6 ext3 1.50 GB
/dev/hda-1 free Hidden 8.37 MB

Anyone have any ideas why the tohd isn't working in this case?

03-30-2005, 07:16 PM
Hmmm. This may be a hardware problem. The CD can't boot MEPIS or Unbutu (Although to be honest I didn't spend any time troubleshooting these failures. As soon as it puked, I took the CD out.), and it had trouble copying the Knoppix 3.7 ISO I burned. (I burned the raw ISO as a file to the CD just for this, and I burned the ISO image for another boot CD.) I fianally had to download the 3.7 ISO from one of the mirrors. Funny, because Knoppix will boot and run fine from the CDROM.

I now boot from the CDROM with the bootfrom=/dev/hda/KOPPIX.iso cheatcode and everyone's happy :)