View Full Version : HD installation doesn't work?

04-02-2005, 11:13 AM

I don't know whether anyone asked this question before:

I got an empty hd and I created two partitions just like in the manual. After that I booted into the Knoppix 3.7 cd-rom and installed linux with "sudo knoppix-installer". By then everything worked without problems and the installation finished without any errors. I said lilo should be installed to the mbr and after all I rebooted my pc. But my computer told me that no operating system is available. What have I done wrong? :(

04-02-2005, 08:15 PM
Someone an idea? It won't work :(

04-02-2005, 08:20 PM
hmm, sounds like it afailed to write the botloadre OR the install failetd at some point.. retry and take note of ANY messages during boot.

04-02-2005, 09:13 PM
That's what I wonder about. There is no message at the terminal over the entire installation. I choose my options, it copies all files and configures it, I decide where the lilo will be written to (I tried both mbr and root partition) and it finishes without any errors. After rebooting my computer just tells me "no operating system" :(

I also tried to install Mandrake 10.1 but it failed cause of "missing" a specific file on cd. I can't believe that because it works fine at other pcs. I believe my computer doesn't want linux :cry:

04-02-2005, 09:27 PM
sounds like you have an older CD reader. that and a CD burnt at higher speed can sometimes do things like this. burn slowly (2-4X) and try to use a diferent brand of media.
and some old CD readers can NOT read the full 700M of a knoppix CD.

04-02-2005, 10:08 PM
I know what you mean but I install from a new dvd-rw burner and it hasn't really problems reading the cds...

It seems mandrake has some problems catching the irq of the hd. What does it mean? May there a general problem?

04-03-2005, 02:18 AM
Two things I can think of:

some bioses have a boot sector blocker which is labelled as an AV package. Effectively this prevents anything writing to the mbr. Make sure it's disabled. (historically most viruses were actually planted on the boot sector, so this was once a good idea :-) )

Try booting with the CD and doing

sudo /sbin/lilo

you could even try sudo /sbin/lilo -b /dev/fd0 (that's zero, not o) with a floppy in the drive which should give you a bootable floppy. man lilo for other ideas.

Let us know how you get on.

04-03-2005, 11:25 AM
some bioses have a boot sector blocker which is labelled as an AV package. Effectively this prevents anything writing to the mbr. Make sure it's disabled. (historically most viruses were actually planted on the boot sector, so this was once a good idea Smile )

Hm... I got an amibios and it doesn't offer an option protecting the mbr or something like that :(

Try booting with the CD and doing

sudo /sbin/lilo

I tried it and that was the answer:

Unrecognized token "! Please edit /etc/lilo.conf before running lilo!" at or above line 20 in file '/etc/lilo.conf'

What can I do? I hoped to install Linux this weekend and nothing won't work till now. Mandrake doesn't start installing because of "missing" a file, the Knoppix installation doesn't really work after setup and I can't try more Linux distributions ...

04-03-2005, 02:56 PM
just post your /etc/lilo.conf here.

it should be easy enough to edit using kwrite or joe

04-03-2005, 03:57 PM
I can't look into this file cause I don't have the authorization :(

At Knoppix, how can I log in as root to access /etc/lilo.conf? Password shoudn't be the problem, but I can't change the user.

04-03-2005, 04:24 PM
I was able to open the file as root. Hope, I don't flood the screen too much:

# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# --------------- `install-mbr(8)', `/usr/share/doc/lilo/',
# and `/usr/share/doc/mbr/'.

# Remove this line when you are done configuring. -KK
"! Please edit /etc/lilo.conf before running lilo!"

# +---------------------------------------------------------------+
# | !! Reminder !! |
# | |
# | Don't forget to run `lilo' after you make changes to this |
# | conffile, `/boot/bootmess.txt', or install a new kernel. The |
# | computer will most likely fail to boot if a kernel-image |
# | post-install script or you don't remember to run `lilo'. |
# | |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.

# Specifies the boot device. This is where Lilo installs its boot
# block. It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. (`/')

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller. Using `compact' is especially recommended when
# booting from a floppy disk. It is disabled here by default
# because it doesn't always work.
# compact

# Installs the specified file as the new boot sector

# Specifies the location of the map file

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration. If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well. Please RTFM `install-mbr(8)'.
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
# delay=20

# You can put a customized boot message up if you like. If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress. `single-key' goes with the `alias' lines in the
# `image' configurations below. eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
# message=/boot/bootmess.txt
# prompt
# single-key
# delay=100
# timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
# vga=ask
# vga=9

# Kernel command line options that apply to all installed images go
# here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
# append=""

# Boot up Linux by default.

append="lang=de apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga=791 quiet BOOT_IMAGE=knoppix"
# restricted
# alias=1

# label=Linux-OLD
# read-only
# optional
# restricted
# alias=2

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
# other=/dev/hda4
# label=HURD
# restricted
# alias=3

What can I do?

04-03-2005, 05:26 PM
OK, to edit it, open up a Terminal and type:

su <return>
(prompt for root password -- type it in) <return>
vim /etc/lilo.conf <return>

(Alternatively, if that doesn't work, try sudo vim /etc/lilo.conf)

vim will pop up with lilo.conf loaded, but the colours will be horrible! Go to >Settings>Schema>Vim Colours (towards the bottom). Hit the "i" key to get into insert mode. Move the cursor with the arrow keys to the line

"! Please edit /etc/lilo.conf before running lilo!"

and type a hash "#" in front of it: bash sees # as a comment, which tells it "ignore this line".

So you have

#"! Please edit /etc/lilo.conf before running lilo!"

Hit the [esc] key to enter command mode.



and you're finished with vim.

Now run


(alternatively sudo /sbin/lilo)

and that's it.

04-03-2005, 05:51 PM
Thanks, I will try it next weekend when I'm back home. I hope, it works then...