View Full Version : debian/knoppix panic - lilo - grub- help

04-16-2005, 12:15 AM
I am brand new to linux but decided to jump in and try to swim anyway, oops :oops:
I chose to install (debian install) to my hd (hda1/ext3) and write lilo to mbr when I did the install. No lilo, but I have grub?
comes up, I have tried and tried different things...latest/farthest

kernel /boot/vmlinuz root=/dev/hda1 devfs=mount
initrd /boot/initrd.img

EXT2-fs: hda1: couldn't mount because of unsupported features (4)
Kernel panic - not sycing: VFS: Unable to mount root fs on unknown-block(3,1)

Should I have used ext2? When starting from cd I can't edit anything on hda1. Need help.

04-16-2005, 03:37 AM
Ah, the mysteries of Grub.......

You can probably find what you need with a Google.

But are you sure you don't have Lilo?


lilo -v

from a terminal as an ordinary user. If you get output like:

LILO version 22.5.9, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2004 John Coffman
Released 08-Apr-2004, and compiled at 15:30:00 on Aug 15 2004
Debian GNU/Linux

/etc/lilo.conf: Permission denied

then you have Lilo.

Just su to root and do:


and you should find you have it on your mbr.

Failing that, post the error message. Some versions seem to have one line in /etc/lilo.conf which needs #ing out.

04-16-2005, 04:51 AM
try putting 'linux' before
kernel /boot/vmlinuz root=/dev/hda1 devfs=mount
initrd /boot/initrd.img

04-17-2005, 04:40 AM
... and write lilo to mbr when I did the install. No lilo, but I have grub?
The knoppix-installer script silently runs GrUB to look for other operating systems on your hard drive. But that's before it asks where you want to install LILO (so it knows what to put in your new /etc/lilo.conf).

So if the installation was successful up through the GrUB step, but borked before it got the bootloader portion of LILO installed, maybe...?

But anyway, yes, the program LILO should be there on your hard drive, whether or not it got set up with a configuration file and then run to install the bootloader.

-- Ed

04-17-2005, 07:41 AM
Should I have used ext2?
No, that's not the problem - ext3 and other journalling filesystems just keep logs of changes so that if a system crashes, for example, it can recover better when it's back up.

When starting from cd I can't edit anything on hda1.
That's not a bug, that's a feature! :D While Knoppix is booting from CD, it looks for partitions and whatnot and writes what it finds to your /etc/fstab (filesystem table) but doesn't mount them yet.

At this point you can mount hda1 with $ sudo mount /mnt/hda1 or, if you're already root, # mount /mnt/hda1. Now you can both read and write to the partition. This is a shortened version of the mount command and only works for filesystems that already have an entry in /etc/fstab.

But if you have the Knoppix CD automount hda1 for you - maybe by clicking on the desktop icon - the partition gets mounted read-only (ro) to protect you from making changes to the hard drive by mistake. (Knoppix installed on hard drive doesn't do this.)

In this case you have to remount the partition with the option read/write (rw). The command (as root) is # mount -o remount rw /mnt/hda1.

There's one more step if you booted from CD but are working on LILO that's installed on hda1 - you have to transport yourself into the hda1 environment so that LILO doesn't look around and get confused by the CD environment. As root (sudo or otherwise), type # chroot /mnt/hda1.

You can edit its configuration file, (/mnt/hda1)/etc/lilo.conf before or after changing root, that doesn't matter. But after you've edited the config file you have to run the lilo command to get the new configuration written to the bootloader, and for this you need to be chrooted.

(Actually, there's still one more gotcha that applies to configuring LILO while you're booted from the CD only if you have more than one Linux installed on the hard drive. This doesn't apply if you have only one Knoppix installed and it's the only Linux, even if you have other operating systems installed like Windows, OS/2, Plan 9, or whatever. I won't clutter up this posting with those details, but let us know if it applies to you.)

So here's what you do when you're booted into the CD and want to make changes to LILO on hda1. I'm going to show the commands as root rather than as sudo because you have to be root anyway to edit /etc/lilo.conf and to run LILO:

(CD)# mount [-o remount rw] /mnt/hda1
(CD)# chroot /mnt/hda1
(hda1)# (do any editing of /etc/lilo.conf)
(hda1)# lilo
(hda1)# exit
Include the part within the if hda1 is already mounted read-only. You can check this by using the bare [b]$ mount command as regular user Knoppix or as root.

I hope this helps.

-- Ed