View Full Version : Advice on enabling ACPI in Knoppix

04-12-2003, 02:38 AM

I just put Knoppix 3.1 on a brand new machine. When knoppix shuts down it does not shut the machine down. I would like it to. I think I may need to recompile the knoppix kernel to include acpi.

I think this because:

- lsmod|grep apm returns no messages

- running insmod apm returns these errors:

Using /lib/modules/2.4.20-xfs/kernel/arch/i386/kernel/apm.o
/lib/modules/2.4.20-xfs/kernel/arch/i386/kernel/apm.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg

lsmod | grep ACPI returns nothing

There is no /proc/acpi

Anyway, I think my machine can ACPI

"Intel Desktop Board D845PESV"....this is also the name of the chipset.

My bios has a menu for power features called "acpi" ( not apci )
It had these options:

silent boot - enabled
intel rapid boot - enabled
scan user flash area - enabled
pxe boot to lan - disabled
usb boot - enabled
chasis intrusion - disabled.

Am I correct in my understanding that Knoppix is not put together in the same way ( kernel wise ) as regular gnu/linux?

I tried looking at some generic docs for recompiling kernels.

executing make[config|xconfig|menuconfig] just produces an error message a
" no rule to make target ( pick one of the previous 3 ) stop. I tried from /usr/src/linux

Anyway, how do I recopile the Knoppix kernel so shutting off knoppix shuts down the machine? I would like to keep everything else about the kernel the same.

Thank in advance for the info


04-12-2003, 02:50 AM
Well, I don't know much about linux, or about ACPI for that matter, but I do know that, in my PC emulator, after logging out, it does shut down the emulator, rather than having to power it down manually. Also, I had tested an older version on a classroom computer, and it shut down properly too, however, I have yet to test this installed on the hard disk, so, my post here is probably useless, but maybe not.

04-14-2003, 07:38 PM
the ACPI is not avalaible on the knopppix kernel ..
klaus just told me that the kernel patch was crashing most of the coputer so he did not patch the kernel .. But wth the live cd the apm is loaded by default if your bios is compatible so .. have a look !! if not try /etc/init.d/apmd
to start the apm sever