PDA

View Full Version : alsa and knoppix 3.8.1



beloncio
04-24-2005, 06:01 PM
Hi.
I have knoppix on hard disk; when he init it dnt charge alsa-module,I havee run
alsaconf.
How it load alsa with initiate of knoppix?
Thanks

Tommer
04-30-2005, 09:34 PM
I've the same problem (also knoppix 3.8.1 on hd). After running alfaconf everything works fine, but after a reboot the sound is gone and I've to run alsaconf again.
I tried the command "alsactl store" already but still no success.

Tom

steev
06-15-2005, 08:24 AM
I was about to post a new topic for this, but found this thread. I too have 3.8.1 on my drive and an nForce2 motherboard. Some sound was working, but things like Realplayer and Skype were silent. Eventually I found out about alsaconf and that got it working using the Intel8x0 driver, but after a reboot I am back to where I was.

I've been looking into the various files in /etc. I got rid of the alsa file that seemed to load all possible drivers. Could there be something else there that is overwriting what alsaconf does?

Thanks

Steve

steev
06-16-2005, 01:09 PM
I had another play with this last night. I found various articles that suggested using 'alsactl store' or adding some lines to /etc/modutils/aliases, but had no luck with these. It looks like a lot of people have had this problem with various distros.

I even looked at the alsaconf script. From what I could make out it tries to add lines to aliases, run update-modules and start alsa, but it looks like nothing happens to modules.conf when I run it. It's obviously doing something that makes the sound work for that session, but I cannot see what it might be.

The search continues. I'm trying to educate myself on things like the boot process in order to try and work it out, but I would welcome any help.

Steve