View Full Version : Unable to connect to internet before and after hdinstall

04-12-2003, 07:08 PM
Hello! I've heard much about knoppix, from friends and from my dad. When i bought the 38th issue of Linux Format, knoppix came with the dvd, and i decided to try it out. :wink:

Unfortunately, I'm unable to connect to internet, or use internet-services, like pinging other machines, and i cant figure out why. :(

:!: I am new to linux, and arent that familiar with configuration-files, where they are and so on. Though i have a few thoughts of what it might be:

1. Some of the configuration-files doesnt allow access to the internet (??)

2. My networkcard (realtek 8139/810x family fast ethernet NIC) isnt supported in the kernel (uses the module 8139too. It works well in kernel 2.2, but i have had problem with it in kernel 2.4)

3. Because of my router (D-link DI-604)

Like i said, Im not so familiar with the configuration-files. So if that is the problem, could you please tell me what files to look at, and maybe tell me what to edit.
When i used debian stable, i had problems with the network card when i tried the kernel 2.4. But it worked perfectly with kernel 2.2. May it be that my networkcard isnt supported in the default knoppix kernel, and do i have to recompile the kernel, and switch to kernel 2.2 again.
My router has never caused problems before, but you can never know? Added it just in case... :roll:

I hope someone know a way to solve my problem

see you around.. :D

04-12-2003, 09:52 PM
I'm not positive but I thought that NIC used the Tulip driver. Maybe you've already seen it but if not there is a netcardconfig tool in Knoppix as well. What driver did your NIC use in the 2.2 kernel?

DOH! try this too:

sudo modprobe 8139too

04-12-2003, 11:28 PM
I get some errors on my systems with rtl8139 NIC's due to wanting an unavailable irq, but usually they will operate OK. They do use the 8139too module.

What kind of system do you have? What kind of video etc?

On motherboards with integrated video often the pci=biosirq boot option will help, I would try booting with:

knoppix pci=biosirq &nbsp[plus any other boot-options required]



04-14-2003, 04:56 AM
Watch the startup script. If Knoppix appears to be detecting the net card, try 'pump -i eth0' from a terminal. I had this happen with Freeduc ...it would connect ok when runnning from the CD but not from the HD. Appears the install scripts leave a few things out when it does the hdinstall.