PDA

View Full Version : apache-dev -> broken packages



danielgarcia
04-14-2003, 06:04 AM
Hi,

I'm trying to setup a midgard cms engine in my knoppix box, however I need to install apache-dev.

I tried several approaches (some of them drove me to "another" reinstall of knoppix :( ), and I haven't succeeded.

Well, the error from apt-get [-f] install apache dev results in:

Sorry, but the following packages have unmet dependencies:
apache-dev: Depends: apache-common (< 1.3.27-0) but 1.3.27-0.1 is to be installed
E: Sorry, broken packages



I'm boldly starting now an dkpg --force approach, but I'd really appreciate if someone "enlightens" :idea: me with a better / correct solution. I'm just a newbie... but already hooked on knoppix :)

TIA,

RockMumbles
04-14-2003, 01:08 PM
you might want to try:

apt-get -t unstable install apache-dev

which will look in the unstable repository instead of the testing repository.

rock

danielgarcia
04-19-2003, 07:50 AM
That worked fine :D.

Thanks a lot !

markleong
12-26-2003, 07:11 AM
I did the install as described above.

However /etc/init.d/apache start does not see to work. How do I start apache-dev?

raduen
01-14-2004, 12:08 AM
I install apt-get -t unstable install apache-de
Want more do I have to install to get midgard on my debian box, I can;t seem to find a working package link?? Please help.