View Full Version : QTParted: "An Error Occured! :("

05-11-2005, 11:54 AM
I'm trying to give knoppix or whatever other distro I want to install a partition on my HD. I have an 80GB drive that is one big NTFS partition for my Win XP pro installation. QTParted tells me this about my current partitions:

number partition type status size used space start end
(windows symbol)01 /UNIONFS/dev/hda1 ntfs Active 74.52GB 58.63GB 0.03MB 74.52GB
02 /UNIONFS/dev/hda-1 free 7.84MB N/A 74.52GB 74.53GB

I don't know the reason for the small 7MB partion.

Here is what I get after it "resize":

number partition type status size used space start end
(windows symbol)01 /UNIONFS/dev/hda1 ntfs Active 69.25GB N/A 0.03MB 69.25GB
02 /UNIONFS/dev/hda-1 free 5.28GB N/A 69.25GB 74.53GB

I make sure my hda is unmounted and "commit":

It works for a while and then I get the error message: "An Error Occured! :("

I've looked around for an answer, but couldn't find one on the QTParted home or here. Help would be appriciated or else I'll have to give up on Linux again. Thanks in advance for any help.

05-11-2005, 06:13 PM
Do you use the latest Knoppix? Qtparted should give more error message.

You could also look for Qtparted's log file. It should be somewhere below /var/log directory but I don't remember the details.

05-12-2005, 10:08 PM
I got the same error. You have to unmount the drive. It should work then.

05-12-2005, 10:26 PM
I had the drive unmounted and was using the most recent Knoppix. I ended up using Partition Magic and it worked perfectly. I got Mandrake installed and I'm good now. Except I broke X Windows after about 45 minutes....

Thanks for the responces.

05-26-2005, 06:02 PM
QTParted (well, actually ntfsresize) checks if NTFS is consistent at first and it refuses resizing if it's not. The error, you had, could indicate that and you should have run chkdsk /f on Windows to safely resize. Partition Magic doesn't check filesystem consistency and even if it looks it did the job right, still Windows can totally collapse later. It seems this happened in your case. That's why I asked tell us what were in your logs ...