View Full Version : How to change user to root

05-18-2005, 09:44 PM
First off I am very new to Linux. My goal is to use the Linux box to serve divx files to my media center which is running 2000. When I follow directions on setting up samba they require changes to the config file which is found in the root folders section. My problem at this point is that when I make changes I cant save them. I assume I need root privleges. I try to login as root but am told by the system that root login is not allowed. How do I change to root and stay that way untill I am satified with the changes? Tried to search man pages but found no clues.

For info. this is a hard drive install with sudo knoppix installer first choice for beginners. Knoppix 3.7.
Should I have chosen a different install selection such as the debain style one (old way)?
I have other questions latter related to shared folders but need to get past this first.

Thanks in advance.

05-18-2005, 11:25 PM
You need to be root to change most configuration files.

open a terminal.


(prompt for root password)

vim /path/to/file

use the arrow keys to navigate. When you get to the line you want to edit, hit the "i" key. You can now edit the lines you want. When you're finished editing, hit the Esc key, and then shift+Z+Z to save.

There is alot more to vim than this, and several vim editors out there.

Alternatively, you could log in as root and use Gvim (which is like a vim with mouse support).

05-18-2005, 11:53 PM
Thanks fingers99 I will try that. However the system will not let me log in as root. How do you log in as root? Maybe I left out an important detail. I'm in the kde gui. I was using file manager to select the file and open it. This would be where I would be most comfortable editing. can I log in as root in the kde enviroment and edit in kwrite or similar editor? Please forgive any stupid questions but I am at the bottom of the food chain here.

05-19-2005, 03:44 AM
Ok. Tried what you said from terminal and it did ask for my password. It then gave me root permission.However when I type the path: /etc/samba/smb.conf it tells me permission denied. Do I need to reinstall to hard drive since I picked the one that said for begginners. It is not a problem since the machine is 100% for linux? Also I just downloaded 3.8.2. If so what type of instal,l as sudo gave me if I remember 3 or for choices?

Thanks again.

p.s. machine seems to run ok otherwise I am using it to type this message.