View Full Version : GERMAN!!!

05-22-2005, 01:17 AM
Hey everyone,

1) I'm writing this from my Windows XP since I can't get internet to work in Linux --HD Install--... Why?
Because when I try to configure my network card it displays everything in GERMAN! (Or maybe some other language that I can't speak in.. I'm pretty sure it's German though). The tricky part = everything else is in English except shell and that network config thing. So... I tried setting up the languages in the Control Panel and found the root-protected options for changing the language. Changed it to English. I also ran the desktop wizard and it prompted me in German. Changed it to English. Guess what? Network config (and shell) is still in German. Not exactly with shell - some of prompts there prompt me in English... And some in German. What the fudge? I also tried changing both to another language I can speak in (Polish) but no luck. Ah... It was in English yesterday!

2. How do I install [ethernet] drivers in Linux?

3. This goes to number one. Couple hours ago when I guessed in all the network config prompts and got the internet to work, I restarted my PC. The configuration did not get saved. I did the same thing again... It looks like it doesn't remember how to connect to my router (the configuration!)... How can I save it?

I'm running the latest version of Linux/Debian with / dual boout with Windows XP Home.


05-22-2005, 03:56 PM
In order to fix the german-shell in Kanotix (close cousin of knoppix) one does this:

first off, go to (as root) /etc/locale.gen file and remove all the lines not of your desired language (saves time later - assuming you want to keep en_US ISO-8859-1) and save that file.

Then, apt-get install localepurge. Localepurge's config will come up during the install and see only the language you have in your locale.gen.

Then, another trick. you need to run as root again the command localepurge

For editing the file, if you are more comfortable not in a shell, you can do ALT+F2 then type kdesu konqueror and give root password. Browse to the locale.gen file in the etc folder and when you doubleclick it kwrite or another editor will come up.

05-22-2005, 04:53 PM
Thanks. I'll try that in a sec.

05-22-2005, 06:11 PM
You know what? This is so fucking rediciolous! Sorry for my bad language but it is. I did EXACTLY what you said (Thank You Very Much... Really) but the damn thing still speaks to me in GERMAN!!! More and more!! I edited the locale gen so I only had 2 lines left beginning with en_us. Restarted. Did the apt-get install localepurge. It came up with an error message (I guess it was...) in GERMAN. How the heck do I supposed to set up a language when the thing is speaking in some other one? After setting the locale gen, I still see choices in the Control Center with all those languages.

Why can't I have root privellages?? I don't want to log back and forth between root and my other accounts!
What's up with all those file permissions??? No one's going to make a network with 1000s of users with free Linux!
And the languages... WTF???

I think I'll just uninstall the damn thing. Excellent bootable disk but totally screwed up hard drive install. Fuck it.

How do I uninstall it? (Just the Debian/Knoppix... I still want Grub and my partitions)


Grh.... Why don't they just release separate iso's with one language on them?

08-26-2006, 12:03 AM
Thanks a lot for the trick for changing the language from German to English when you run an application with root privileges on KDE, it work's great. I just followed your steps and Voula !!. Bye


Ps: Sorry for my bad English, I'm from Chile

09-22-2006, 02:54 AM
Time to revive an old post....

Thank you for the step by step on choosing your language.

This probably did not work for Krogen because he did not have internet access.

Here are the steps I followed.

1)ALT+F2 then type kdesu konqueror and give root password. Browse to the locale.gen file in the etc folder and when you doubleclick it kwrite or another editor will come up. Delete all of the languages that you do not want. In my case I wanted US_EN ISO-8859-1. Click the save icon.

2)Open a shell. Enter: su and enter root password

3)Enter: apt-get install localepurge
This will install localpurge.

4)Enter: localepurge

Thats it.... no rebooting needed.

09-26-2006, 08:22 AM
i had the same problem, changing the locale file fixed it, ty! :)