View Full Version : Apt problems - I've broken Firefox!

05-23-2005, 01:23 PM
Ok, I tried to update the Firefox on the Knoppix CD to the latest version using
apt-get install -tunstable mozilla-firefoxThis has worked fine in the past, but after downloading and installing the dependencies, KPackage now tells me that the status of mozilla-firefox is "install reinstreq half-installed"

I tried to uninstall mozilla-firefox and start again, but I get the following:
(Reading database ... 114517 files and directories currently installed.)
Removing mozilla-firefox-locale-de-de ...
/var/lib/dpkg/info/mozilla-firefox-locale-de-de.postrm: line 12: update-mozilla-firefox-chrome: command not found
dpkg: error processing mozilla-firefox-locale-de-de (--remove):
subprocess post-removal script returned error exit status 127
dpkg: mozilla-firefox: dependency problems, but removing anyway as you request:
mozilla-firefox-locale-de-de depends on mozilla-firefox (>= 1.0-3).
mozilla-firefox-locale-de-de depends on mozilla-firefox (<< 1.0.999).
dpkg: error processing mozilla-firefox (--remove):
Package is in a very bad inconsistent state - you should
reinstall it before attempting a removal.
Errors were encountered while processing:
: Sub-process /usr/bin/dpkg returned an error code (1)
I also tried
apt-get -f installbut got
(Reading database ... 114518 files and directories currently installed.)
Preparing to replace mozilla-firefox 1.0.4-2 (using .../mozilla-firefox_1.0.4-2_i386.deb) ...
Unpacking replacement mozilla-firefox ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
E: Sub-process /usr/bin/dpkg received a segmentation fault.

Can anyone help?