View Full Version : HDD install - IPOD mini

06-15-2005, 06:56 AM

Does anyone have an IPOD mini working with the HDD install? I'm having trouble accessing mine. Dmesg shows that it's detecting a USB device, but it doesn't seem to assign it to UBA1 or anything.


06-15-2005, 08:35 PM
No experience of iPod, but try (as root):

mount -t vfat /dev/sda1 /mnt

cd to /mnt and see if you can see anything.

06-16-2005, 05:13 PM
I can try later today, but shouldn't it be UBA-something? I'm connecting with USB. I thought I read somewhere that Knoppix only uses this UBA thing for USB, and not the SDA thing anymore.

06-17-2005, 12:46 AM
Pretty sure it should be sda1 (it could be sda).

Anyway, try it. Then you'll need something like:

/dev/sda1 /mnt/iPod vfat rw,noauto,sync 0 0

in your /etc/fstab

(of course, you'll have to do -- as root --

cd /mnt
mkdir iPod


Let us know how you get on: the sync entry is important for mass storage devices.

06-18-2005, 06:03 PM
No luck! I get "not a valid block device." Any other suggestions?

Thanks for the help.

BTW, I have kernel 2.6.11.

06-19-2005, 06:21 PM
No luck! I get "not a valid block device." Any other suggestions?

Is the iPod powered up and on? I ask because this was exactly the error message I used to get when my Neuros wasn't running: in effect, you're trying to mount a dead device which the OS sees as no device whatsoever.

Other than that, I'm stumped. :-(

06-20-2005, 06:21 AM
Yeah, it's giving me the "don't disconnect" message.

06-20-2005, 07:48 PM
Ah, I've just discovered that some iPods are formatted vfat (as are all Neuroses, iRivers and so on) while others are formatted hfss (wierd harold Mac format). Here (http://www.cavecanen.org/linux/ipod/) for details.

So -- given you have support for the strange Mac filing system -- then

mount -t hfsplus /dev/sda3 /mnt

should do it

if not, try

mount -t hfsplus /dev/sda3 /mnt/

But the url above looks very useful.

06-20-2005, 09:36 PM
Thanks. I will try that tonight and post the results.

06-21-2005, 04:13 PM
No luck. I got "not a valid block device."

06-21-2005, 06:58 PM
Curiouser and curiouser. It's got to be one fs or the other, and it pretty much must be either sda, sda1,sda2 or sda3.

Can you try copying and pasting the codes I've given you in an xterm?

06-24-2005, 07:41 PM
I have my Ipod mini working perfectly with my Knoppix 3.9 hd install. I installed gtkpod from the new debian stable release before I did the rest of this.

Here are some of the tweaks I had to do in order to get there, though. First, I got an ieee1394 to ipod adapter because I don't have USB 2.0 on my machine, only usb 1.1. I do have a firewire port. Second, I added hfsplus support to my modules list. In the /etc/modules-2.6.11 file I added hfsplus (My knoppix install was beginner, multi-user hardware detection). I didn't fiddle with fstab, since when knoppix boots, if I have the ipod mini attached, it detects it as /dev/sda. I get three partitions when I do this. /dev/sda3 is the one for data.

Third, As root (and I can only use the Ipod as root, so I guess it isn't perfect :wink: ) I mount the Ipod mini with:
# mount -t hfsplus /dev/sda3 /mnt/sda3

As root, I run gtkpod. I had to change the preferences there to use the /mnt/sda3 mount point. I created the directory structure on the ipod, and added mp3's.

Other than the trial and error frustrations of finding all this stuff out, I have had no problems since. I have loaded over 800 mp3's, added text files under Notes, deleted songs, made and edited playlists, and edited the song info, perfectly.

Good Luck.

06-29-2005, 09:05 AM
Thanks for the tips, Otomone. I'm using USB, not firewire, though. I added hfsplus to the modules list per your suggestion, but still no luck.

07-07-2005, 12:40 AM
I just had a bad news/good news experience with the ipod mini. Being curious, I took my ipod mini to work and tried using it with Windows XP. I wanted to see what the official software looked like. As a result I learned a couple of things:

1. Windows reformats the ipod when you load the software, so all my songs and playlists were wiped.
2. Windows seemed to hang when I tried a USB 1.1 port. Evan, is your USB 2.0 for sure?(KinfoCenter will tell you.)
3. After losing all my music and playlists, I now have a vfat format ipod mini that works better now. I have put it in my fstab and now I can mount it without being root, and gtkpod works as a regular user, too.

So, I'd suggest this:

If you have any access to a Windows XP machine with USB 2.0 ports, load the ipod mini software drivers, but not iTunes. Let XP reformat your mini. Run the iPod Updater to make sure all the firmware is up to date. Then see if you can mount the ipod mini as a vfat volume. (okay, I use Windows at work. They make me :roll: )

Good Luck.

07-07-2005, 07:47 AM
Thanks for the help! So far, not working. I used Windows 2000 Server and not XP, so perhaps that's the problem.

Is there a way to check if the ipod mini is formatted vfat now? I tried mounting uba1-4 and sda1-4 with "-t vfat." Nothing. I'll try again tomorrow. Any more tips?

Thanks again.

07-07-2005, 08:35 PM
Is there a way to check if the ipod mini is formatted vfat now? I tried mounting uba1-4 and sda1-4 with "-t vfat." Nothing. I'll try again tomorrow. Any more tips?

The iPod mini should tell you that itself. From the main menu choose Settings-->About and look for "Format" Mine says "Windows" now.

07-07-2005, 10:09 PM
dude search ipod in this forum , theres soemthing about a software ipod-gtk , eithere way search you'll find the answer quickly