View Full Version : Can't navigate file folders

06-24-2005, 02:50 AM
Can anyone point me to the solution...?

One minute it worked perfectly - I could click on the hda1 or hbd1 or CDROM or Floppy icon on the desktop, and the relevant folder would open. I could copy and paste, move files around, and do all the file management things I want.

The next minute, clicking on a file folder on the desktop brings up the message "Sorry - Kdesktop. KDEInit could not launch'/mnt/hda1' " (or whichever drive I click on).

I tried various actions, none of which fixed it. Rebooting did not bring back the file folder function either. I can get to the folder contents and navigate normally by using File Manager in SuperUser mode, but shouldn't need to do that.

I've searched the forums and Google but found no answer.

What do I do to get the file folders back?

It's Knoppix 3.8.2 installed on the hard drive of an old Pentium 600MHz machine with 512MB of RAM and three hard drives, one CDROM drive, and one floppy drive.

06-24-2005, 03:07 AM
This is known issue. Unfortunatelly, I forget the solution. I restart Konqueror and it works again, or wait a bit. There is something here t+could+not+launch&hl=en
"dont launch it from kwrite as root, instead use kdesu kwrite as a regular user"

06-24-2005, 10:55 PM
Thanks for that. I've made the change to menu-xdg as suggested there anyway - I was having the same problem with some changes not being kept after a reboot.

But I've had the " KDEInit could not launch'/mnt/hda1' " problem for ten days or so, and nothing changes despite many restarts. What I do notice is:

- Konqueror in su mode can flip up and down the folder tree with no problems;
- If I set konqueror to open each folder in a new window, it works fine when I click on folders. But if I leave it set to use the same window, I get this problem.

It's as if konqueror not in su mode didn't have sufficient permissions for something. The main annoyance is that I have all the main folders on the desktop, but can't open them by clicking. I've cheated, and can get there by another way, but it isn't right.

06-28-2005, 01:33 PM
Lots of frustrating further investigation later, and after a reboot, I tried to open a drive that wasn't "mounted" and got a different error message - "mount - only root can do that". It seems like permissions are screwed up somewhere. I wonder what piece of software needs root permission to mount a hard drive so that I can view the contents. Or has a file somewhere with access rights been corrupted?

07-03-2005, 05:49 PM
AT LAST! Problem solved. At some point, a file somewhere had got corrupted and Knoppix was trying to use Rosegarden as its file manager for anything clicked from the desktop.

Control Panel - KDE Components - File Associations - inode - directory and remove Rosegarden, add Konqueror, and all is well. Phew!

It took a while to find, because "inode" is not a term I know.