View Full Version : Cd rom is not recognizing music cd's

06-29-2005, 07:53 AM
ok the cd rom doesn't appear when i put in the tray a music cd , how can i fix this? please help me , thankls!

im using Knoppix 3.9

06-29-2005, 04:03 PM
I'm trying to get the same information, see the topic"Woes Using CD's".

Can you see data CDs, and not just music CD's?

06-29-2005, 04:15 PM
You can't mount and browse an audio cd as there is no filesystem on it. Thus you can only mount data cds.

06-29-2005, 04:29 PM
ok the cd rom doesn't appear when i put in the tray a music cd , how can i fix this? please help me , thankls!

im using Knoppix 3.9

Going along with Markus here, can you play the CD with xmms, or kscd?

07-01-2005, 06:53 AM
no i can't i can only see them with k3b but can't play em

07-01-2005, 09:19 AM
I take it you mean that you can mount data cd's, and couldn't play a cd with kscd either.
Here's my settings for kscd:

Configure kscd
CD Player
CD-ROM Device
Check: Use direct digital playback
and for xmms:

xmms -> options -> preferences
Input plugins
AudioCD Reader
Check: Enable Plugin
Default CD Device: /dev/hdc (do "dmesg |grep CD" to find it)
Play Audio CD Directly
Volume setting
CDROM drive
CD Audio Player
Device: /dev/hdc
Directory: /cdrom/ (use your mountpoint as in /etc/fstab)
Play mode: Digital audio extraction
Output Plugin
Alsa (choose OSS if you use it)
Device settings
Audio device:
Check: Use software volume control

07-01-2005, 09:29 AM
I had the same problem, and nobody could answer what to do. Eventually I got it working after much messing with downloads and stuff.

It works now with KSCD.

I've just waded throught my notes (I keep a scruffy written log of what I do to try to get bits of linux working, so that I don't waste time doing the same thing again if it doesn't work). That says I installed XfreeCD off the Kpackage utility and ran it, and CDs would then play with KSCD. There's obviously something somewhere that needs to be configured, or turned on, or poked in the eye, and XfreeCD does it whereas Knoppix install and KSCD don't.

Thereafter, XfreeCD wouldn't work - it crashed whenever I started it, but KSCD works fine. I removed XfreeCD.

I've not yet been able to inspect the contents of music CDs in Linux, though. I use WIndows for those rare occasions I want to see what's actually on a CD.

One warning: don't load packages called aRts... - they jammed up my soundcard config so that the card doesn't appear unless I run alsaconf at every bootup. They can't be removed: if I try to remove them with Kpackage, it shows that it's also going to remove all the related packages, which includes everything on the machine. I've done too much work on setting up this machine to wipe the lot and start again (though it's tempting sometimes at 2am).