View Full Version : KWifi - DHCP

07-05-2005, 05:00 PM
I am unable to get a DHCP address with KWifi (although it says I'm connected).
Here's what I've got:
Proxim Orinoco b/g (atheros chipset) How can I set it to automatically choose DHCP when I connect?

07-05-2005, 08:37 PM
Unfortunately, in this stage of Linux's maturing process, it's still pretty much mandatory that you use the command line or shell scripts to change your wireless interfaces' settings.
If you wish to connect to a specific network, use this command:
iwconfig <interface> essid <SSID> commit
If you wish to connect to a WEP encrypted network, use this command:
iwconfig <interface> essid <SSID> enc <key> commit
lastly, once you have made these changes, run one of these commands:
pump -i <interface>

If you have more questions, post back.

07-06-2005, 04:10 AM
dhclient = "comand not found"
I've tried the iwconfig as well, it does the same thing as Kwifi manager. KWifi manager is just pretty much a GUI for iwconfig. pump -i ath0 seems to work though, thank you!