View Full Version : Debian : how can i install my sound card?

07-12-2005, 01:49 PM
can anybody help me , ? i mean what command do i have to use there's no alsa and soundconf doesnt work either , please help :)

07-12-2005, 03:18 PM
Try alsaconf but only after checking that volumes are pumped up in aumix, alsamixer and kmix. At least PCM should be at ~70.
If alsaconf isn't recognised: apt-get install alsa-utils

07-12-2005, 08:11 PM
ok it worked , but it said that the modules aren't there li
nuxserver:/home/admin# alsaconf
modinfo: snd: no module by that name found
modinfo: snd: no module by that name found
modinfo: snd: no module by that name found
Unloading ALSA sound driver modules: (none loaded).
Building card database...
modinfo: snd-opl3sa2: no module by that name found
modinfo: snd-cs4236: no module by that name found
modinfo: snd-cs4232: no module by that name found
modinfo: snd-cs4231: no module by that name found
modinfo: snd-es18xx: no module by that name found
modinfo: snd-es1688: no module by that name found
modinfo: snd-sb16: no module by that name found
modinfo: snd-sb8: no module by that name found
any way to fix this ?

What are the names of the alsa modules to apt-get them , i tried alsa-modules and it doesn;t work , if in the ftp debian site , and i can see a folder called that , but i cant apt-get it cause i don't know the name of the packages

07-12-2005, 09:15 PM
Umm, is this knoppix debian style, or debian pure?
Check if alsa is compiled in to the kernel or as modules with: gunzip < /proc/config.gz |grep SND
You can't apt-get the modules, they have to be compiled in your kernel, into it or as loadable modules.
You can create the modules with module-assistant which you might have to apt-get. Needs kernel source. Try loading with modconf first though.
Have a look at http://www.linuxquestions.org/questions/showthread.php?s=&threadid=224547 if this is debian.

07-12-2005, 09:39 PM
im using Debian , ok i fixed the problem i did apt-get install alsa* to download all the alsa packages , 'cause when i downloaded the alsa-utils , it didnt' download all the packages that it should have :)

07-12-2005, 11:39 PM
now i have a new problem it seems , that it installed the modules , and identiffied the soundcard but after configuring it it said , device not found ! , i don't lknow if it gots to do with the kernel version , that the modules i downloaded can't be compiled in 2.4 kernel , please help , i don't know what to do , should i reinstall and use the cheatcode for kernel 2.,6 please help ! aaaaaaaaah

yeah the modules didn't work with the kernel so i apt-get the kernel 2.6 image now all is working , thanlks a lot!!!!!!

07-13-2005, 07:08 AM
You're welcome since I didn't even do anything :)
I suggest mentioning clearly that you are using debian instead of knoppix so that even dense people like me realise it :D

02-28-2006, 06:19 AM
i just installed debian and have a similar problem. i'm running the 2.6 kernel, but when i do a alsaconf, it doesn't find my card. what can i do?